NextCloud Installation Q & A

  • I haven't see this error before.Double check your vhost codes.


    If this NC installation folder is in your OS drive, then you may need to add this to your vhost options; change it accordingly to your need:


    Code
    # Path to the root of your installation
    root /var/www/nextcloud/;

    I went to the instructions and installed it to /media/UUID/www/nextcloud

  • This has to do with your upload max size settings.



    Look in the .user.ini file.


    /www/nextcloud/.user.ini


    It looks like this:


    Code
    upload_max_filesize=50G
    post_max_size=50G
    memory_limit=512M
    mbstring.func_overload=0
    always_populate_raw_post_data=-1
    default_charset='UTF-8'
    output_buffering=0
  • Hi,


    I have followed all your steps until step nr. 8 but now, after the installation is done, and I want to login I get the error in Chrome Safari and Firefox that the login page loops (redirects). What should I change to stop this loop?

  • Trusted domains should be fine as I am using for now just internal network.



    In Chrome I have this error:


    The 192.168.0.192 page isn’t working


    192.168.0.192 redirected you too many times.

    ERR_TOO_MANY_REDIRECTS



    In Firefox same ... too many redirects


    And this in Safari:


    I tried several times to install again and again, also OMV I have removed and configured again. I used also more VM and different browsers and port's but error is the same.

  • Look in step 2, ensure the "Default Config" is disabled.
    By the way, you don't need to put in the port # in the config.php.


    Did you add any additional codes to the vhost?
    Clear your browser's histories/cookies, and restart the server.

  • Default Config is disabled. I also have removed the port 90 from config.php and clear the histories and cookies. I also installed a new VM to see from there if is working. Still the same result. I didn't added any additional codes to the vhost.


    I have a default config of OMV installed on a proxmox. After install I made just the updated and installed the extras.


    I have tested also OwnCloud and it was working for OwnCloud.

  • If i use my nextcloud app on my s7edge i get "A unknown error occured" ("Ein unbekannter Fehler ist aufgetreten")
    Have you any ideas what I can do to fix this?

    That's a generic error doesn't state the cause.
    Perhaps look in the NC forum.


    @alexpad,


    Do you running another web server beside NC?
    I assuming you aren't using SSL, so turn https off.


    fastcgi_param HTTPS off;



    Try the OwnCloud codes, and let me know if it works for you.


  • @tinh_x7


    NC is the only web server that I am running.


    From your original settings I have changed the setting:
    fastcgi_param HTTPS off;


    after this it started working.


    I also used the OwnCloud codes that you have provided but still the HTTPS need's to be off. So for me it's not working in case that HTTPS redirect is ON.


    Thanks, you made it working.



    Other topic will be, in case that I will have a SSL Certificate and I want to enable HTTP do you think will work if I change back to on?


    But until then I am testing NC with http just, so ... thanks for your help.

  • That's a generic error doesn't state the cause.
    Perhaps look in the NC forum.

    If I use your settings for nginx-server I get this error message.
    If I use this settings

    then I can use my nextcloud app on my s7edge

  • @kruto,


    I think this could be a bug on Galaxy S7 edge, are you using the browser or a NC app?
    I don't have this issue on my iPhone.


    FYI: those codes are for OwnCloud.


    Other topic will be, in case that I will have a SSL Certificate and I want to enable HTTP do you think will work if I change back to on?


    Since you've tried NC and OC codes, and you got the same error, that meant the codes are not culprit.
    I believe your Nginx settings or something else is trigger the loop.





    Ensure that you do not enable any default server option on, and only use ssl is disabled.


    Can you post your server settings (step 1f) ?

  • Don't know if this help any new users, but I wrote a small script for prerequisite dependencies installation, and download & extract NC zip files.
    I haven't test it yet.


    1. Save the script as 'nc_installation.sh".
    2. Change the nextcloud_path variable accordingly.
    3 Then chmod +x nc_installation.sh
    4. Run the script: ./nc_installation.sh

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!