Docker - "Docker not installed" OMV2.0

  • Same problem here.
    Hope someone can help in this, since I'm unable to enable the plugin neither...

    DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:


    My NAS:
    Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
    with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup


    Plugin list:
    Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
    _____________________________________________________________________________________________________________________________


    Quote

    The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.

  • I've had this same issue. Ryecoaaron, how can I install 0.2.23? I've done apt clean/update, etc, but my OMV update manager and OMV plugins still show 0.2.22 only, no .23. Is there something else I need to do to be able to see the new version, or is there some lag for the update to be seen? Thx for your help!

  • Is there something else I need to do to be able to see the new version, or is there some lag for the update to be seen? Thx for your help!

    Not sure. It is in both docker repos. What is the output of: apt-get update

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yea, I saw that it was in the repos too. I'm sure it's something with my system, just not sure what. Here's the output from apt-get update:


  • Hi,


    First time poster, long time lurker... not sure if this is relevant or not, but if I look at https://bintray.com/openmediav…iavault-docker-gui/0.2.23 vs https://bintray.com/openmediav…iavault-docker-gui/0.2.22 , 0.2.22 seems to be indexed for Wheezy, while 0.2.23 is indexed for Jessie. Could this mean that it's being ignored? Not sure if I'm looking in the right place, so this could be a complete red herring!


    Cheers,


    PK.

  • I got the same error. It seems that the installation routine for Docker is not finished. I had to first clear the apt cache of the Docker repos. After that I opened the shell and deinstalled any docker related with "apt-get purge docker*".
    Then clear the whole apt cache of OMV via GUI to install later docker again. Cheers Josh

  • I am running OMV 2.2.14 and am stuck. I can only install openmediavault-docker-gui_0.2.22. The 0.2.23 version is not shown as being available when I run apt-cache policy openmediavault-docker-gui.


    I have tried clearing the apt cache, but still can't get to v 0.2.23


    Where did you get the 0.2.23 deb package to manually upload?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • fred@omv:~$ apt-cache policy openmediavault-docker-gui
    openmediavault-docker-gui:
    Installed: (none)
    Candidate: 0.2.22
    Version table:
    0.2.22 0
    500 https://dl.bintray.com/openmed…opers/stoneburner-docker/ wheezy/main amd64 Packages
    100 /var/lib/dpkg/status
    0.2.21 0
    500 https://dl.bintray.com/openmed…opers/stoneburner-docker/ wheezy/main amd64 Packages
    0.2.17 0
    500 https://dl.bintray.com/openmed…opers/stoneburner-docker/ wheezy/main amd64 Packages
    0.2.15 0
    500 https://dl.bintray.com/openmed…opers/stoneburner-docker/ wheezy/main amd64 Packages

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Fixed now, thanx!


    Edit: I can get the latest 0.2.23 but it has problems. More later.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

    Edited once, last by gderf ().

  • I changed the Docker base path to a shared folder on one of my data drives. But when I save the settings it times out with Gateway Timeout and the plugin remains unenabled. I think I'll wait till I upgrade to OMV 3. Thanks for your time.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!