Multi-Port external storage box shows only one disk

  • Hi there!

    Fantec QB-35US3-6G (external storage box with 4 bays) only recognizes one drive; all other drives from the box are not available.

    Some days ago, I startet with my OMV-Project (moving my spreaded disks from windows-platform into a new case, controlled by OMV), till now it seems to run quite perfect, but at the moment I have a problem and no clue!?
    Each time, I put more than one disk in my box, OMV has problems in showing me the "File System"-menu entry or the "Physical Disks" in the GUI (Messages: connection timeout, bad gateway), startup-prozess tell me, that it can not find some /dev/disk-by-label-dataxx-device. I turned Mr. Google on and he told me several things about "activating multiple LUN support" on, for example these links:…e-lun-support-in-linux%3F…latte-erkannt-solved/?l=1

    So, I'm a noob in Linux-configuration, but most/all of this information wasn't suitable, either because kernel-feature wasn't compiled or wrong distribution an so an.
    I hope somebody can tell me how to set up my box in a correct way or active multiple LUNs or some other tipps.

    Some Facts
    OMV-Version: 3.0.7
    Kernel-Version: 4.8.0-0.bpo.2-amd64
    Mainboard: GIGABYTE GA-B250M-DS3H
    External Storage-Box: Fantec QB-35US3-6G

    Thank you for any tipps and help!

  • I have the idea that the case is passing the USB controller as device, just like a USB data adapter will do. So Omv sees no unique disk id, can it be possible that all disks have the same label ? If you plug all disk enter ssh console can you post

    tree /dev/disk -a

    Install tree first. (apt-get install tree)

    Btw I don't think lun is related. That's for using block devices across the network (iscsi)

  • No, I think label and UUID are different:

  • You have a lot of disks there. You can try an increase the web server timeout see if the physical disk display shows correctly

    take a look at this post

    OMV Web GUI Timeout too Low or S.M.A.R.T. Issue

    The character he points out the # needs to be replaced by a number.
    Maybe try to go 120s and test.

  • I changed the existing values, added /etc/default/openmediavault: OMV_HTTPREQUEST_TIMEOUT and restarted all devices. Then I tried to list the content of disk09 or disk 10 (both in external box) via ssh and I got the following message which seems to be similar like the respond from GUI (by the way: even the GUI-respond starts "immediately" which means after 10 seconds):

    root@omv:~# ls /srv/dev-disk-by-label-data09/data/
    ls: Zugriff auf /srv/dev-disk-by-label-data09/data/ nicht möglich: Eingabe-/Ausgabefehler

    German language output which means "Access to /srv/... not possible: Input-/Outputerror.

    From other devices (for example disk08 which is internal), there's no problem from ssh to list content; tree-command like you gave me above is also working after the Input-/Outputerror-Message.

    @LUN: Lots of people have problems with for example card reader, etc. based on USB when connecting them to a linux-system; some more link-examples, hope I got the point:…est4/sparc/SCSI_MULTI_LUN

    Ok, this information is not brand new, but I could not find this setting in OMV, so I tought it might be the problem?


    Update: I don't know why or how but this time, I got an error-dialog from GUI:

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; blockdev --getsize64 '/dev/sdm' 2>&1' with exit code '1': blockdev: cannot open /dev/sdm: No such device or address
    Error #0: exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; blockdev --getsize64 '/dev/sdm' 2>&1' with exit code '1': blockdev: cannot open /dev/sdm: No such device or address' in /usr/share/php/openmediavault/system/ Stack trace: #0 /usr/share/php/openmediavault/system/ OMV\System\Process->execute(Array) #1 /usr/share/openmediavault/engined/rpc/ OMV\System\BlockDevice->getSize() #2 [internal function]: OMVRpcServiceDiskMgmt->enumerateDevices(NULL, Array) #3 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array) #4 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethod('enumerateDevice...', NULL, Array) #5 [internal function]: OMVRpcServiceDiskMgmt->getList(Array, Array) #6 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array) #7 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array) #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('DiskMgmt', 'getList', Array, Array, 1) #9 {main}

    But I guess, this only means that it cannot access some device (sdm); sdm is disk10, a disk without access even from shell.

  • IO error could be the disk failing. You can try the following reboot the server without the box plugged.
    Once the server is up again plug the disk box. Wait a few seconds then run in ssh:

    Paste the output in web text service and put the link here

    Also see if you can list the smart values of sdn and sdm

    smartctl -a /dev/sdn

  • Attached, you'll find the output, incl. sdm, sdn, sdo. I cannot bring you all smart-information about the disk inserted in the 4bay-box, because I got an error: Read Device Identity failed: empty IDENTIFY data.

    So, I put them one after the other in ANOTHER (only one slot) storage box; the reason is that I did not get any infos after the "attributes"-block (Read SMART Log Directory failed; Read SMART Error Log failed; Read SMART Self-test Log failed; Read SMART Selective Self-test Log failed; always with an explanation like "The waiting time for the connection has expired") when putting the disks in the 4bay-box. Hope, these smart-values are valid when located inside a box - if it's necessary, I connect them with an internal SATA-Port.

    Btw: When I shut the system down, there is a "stop job running for device 09/10/11" for minutes - only for the disks in the 4bay-box.
    Btw2: When I read smart-values from a disk in the 4bay-drive, it lasts a long time and maybe a timeout occurs. When I put the same disk into a single-slot-box, everything seems to be ok?

    Maybe I should forget about the 4bay-enclosure? It doesn't seem to be compatible with either operation system or the mainboard?!

  • Kernel: 4.8.0-0.bpo.2-amd64

    Update: Your links told me to try it with USB 2.0; so I changed the USB-Port, but the result is finally the same; with one disk, everything looks quite promising (better than with USB 3.0 - fast, no errors), but atm with more plugged drives, dmesg shows me infos like:

    [ 428.747794] sd 19:0:0:1: rejecting I/O to offline device
    [ 428.748053] sd 19:0:0:1: rejecting I/O to offline device
    [ 428.748205] sd 19:0:0:1: rejecting I/O to offline device
    [ 428.748343] sd 19:0:0:1: rejecting I/O to offline device
    [ 428.748535] sd 19:0:0:1: rejecting I/O to offline device
  • I managed to run a live-demo of Ubuntu 17.04 on my OMV-PC; first I thought, it would work fine - I cannot write anything (guess this means, that I only have read-permissions), but for a few moment, it works fine, could send a "dmesg". But little later, it's not possible to interact with this Ubuntu-demo; not sure atm, if there's a problem with my keyboard or some services aren't run correctly?! Will have more investigations on sunday.

    Is it possible to take a look via SSH and putty on this live-view-installation or is this feature disabled on live-demo?

  • I can't remember if you can install software in live desktop you can try

    apt-get install openssh-server

    then systemctl start ssh

    BTW i took a look at smart data again and this disk

    ST2000DL003-9VT166 barracuda green serial number 5YD2ZK7B

    has lots of errors in Hardware_ECC_Recovered an Command_Timeout, this is usually problems with cable or maybe the contact sata port.
    Maybe try to keep this disk off the box or identify the position in the box it was using, could be a faulty slot there.

  • I tried the ubuntu-live-system; the test-scenario wasn't as meaningful as I wanted it to be, but as conclusio: It seams, ubuntu accept this controller / usb-4-bay-box.

    First of all, I didn't really had much permission; even as sudo, it was not possible (for me) to write any files (folders were possible) or to access some cifs-shares or install something and so on; this is the reason why I have no dmesg-info as file atm. The system was stable, I could read the content of two disks (no ST2000DL003-9VT166) enclosured in the 4-bay-drive; in this constellation, OMV already had problems.

    What will I do next? I guess, I'll not use my 4-bay-box anymore in combination with OMV - except, I get some info how to manipulate some modules.conf-file change settings (CONFIG_SCSI_MULTI_LUN) or OMV supports my controller in future (don't know how to realize this ;)).

    subzero79: Thanks a lot for your support and your quick responses! Even if the problem isn't solved, I learned lot of things about debian-mechanism, so time wasn't wasted at all!

  • Hi, I have a FANTEC QB-35US3R and want to use it with OMV, also. I have a HDD with EXT4 which is running in my other OMV at the moment. I was wondering if I could just unplug it and plug it into the Fantec. The Fantec is a standalone hardware controller for RAID. So maybe your behaviour is due to some settings you made for the RAID on the controller. This is exactly what I would try to avoid. I only want to use it as a USB-extension for SATA ports and then configure the file system with SnapRaid via OMV.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!