Some games on the OMV storage won't work

  • Hi there,

    I'm literally clueless here, hopefully somebody will come up with a good idea, because I googled a lot already (maybe badly) and couldn't find anything about this issue. Maybe I did something wrong, or there are tweaks to do, or what i want to achieve is impossible. Any case, I'd love to know.

    You will find some screenshots that might tell the most experienced of you more than any of my words.

    # Configuration
    - Server: OMV 3
    - Protocol: SMB with auth
    - Client: Windows 10, drive mounted as D:\

    # Issue
    Some Steam games installed on the NAS (main library on this drive) will fail to start while other work just fine.
    Seems like those which will fail are those with the most strict anti-cheat systems. For instance, GTA V failed (Rockstar social club crash upon start), as well as Rust (Rust Launcher Error: LauncherInvalidParameter - Invalid game executable: RustClient.exe).
    Other than that, I am able to read and write anything, so I'm not sure if it fails because of permissions or the simple fact of being a network drive;

    # What I tried
    - Reinstalling Rust > No luck
    - Playing around with ACL: Put UltimateByte (SMB user) as the owner with recursive rwx permissions. Of course, Read/Write is ticked for the user upon User/Group permissions
    - Playing around with Windows Permissions

    # Background
    I Installed my OMV NAS a few days ago. I converted all disks from NTFS to EXT4 (by emptying them, then formatting them then putting back my data), then fixed permissions with ACL. Main goal was to free my main gig from any mechanical drive to make it as quiet as possible and this goal was achieved and I'm happy with it. However this issue's breaking my joy.

    # Hardware
    Case: Fractal Define R3
    PSU: Be Quiet 500w modular Gold
    Motherboard: Asus Z87 Pro V Edition
    RAM : Corsair 2x4GB DDR3 2133Mhz CL9
    CPU: Intel Celeron G1840 @ 2,8Ghz
    GPU: None
    System Drive : SanDisk SSD SDSSDA12 120GB
    Drives : 3x 4TB Seagate ST4000DM000-1F21 (independent, no RAID) + 1x 3TB Western Digital WD30EZRX-00M

    Thanks to anyone who takes some time trying to help.

  • enable permission hieritance and ACL related properties on SMB Share, after that you need to propagate new ACL on Modify Shared Folder ACL to be sure that is propagated.

  • Thanks a lot for your answer.

    I should have mentioned, but then my post would have been even longer, but I had ACL options set as you said when i first made the share. I disabled it for testing purposes.

    As advised, I just did the following :
    - I ticked back "Inheric ACLs" onto the SMB share as well as "Inherit permissions".
    - Then i went back to ACL onto the share within Shared Folders, ticked "Apply permissions to files and subfolders" and "Replace all existing permissions" and applied.

    Then I tried to start Rust again > Still the same issue unfortunately.

    If you got any other idea, i'd take anything :)

  • what user do you use to login in your SMB share (from windows)?

    must be UltimateByte, not root or other.

  • OMV data drives are usually mounted with the noexec flag, which means that programs won't run from them. I'm not sure if this applies to Windows on an SMB share.

    You can try removing the noexec flag from the /etc/fstab to see if that changes anything.

  • No problem @raulfg3 , thanks already for trying!

    Sadly, no luck with this @Nibb31.

    Here is what I did exactly, so that you can check my procedure.

    So i went editing my /etc/fstab with nano

    From this

    /dev/disk/by-label/Data /srv/dev-disk-by-label-Data ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2

    To this

    /dev/disk/by-label/Data /srv/dev-disk-by-label-Data ext4 defaults,nofail,user_xattr,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2

    Then ran

    mount -a

    Tried to start Rust > error
    So I rebooted the NAS
    Tried to start Rust again > error
    So I stopped Steam, disabled and re-enabled my network connection onto the Windows Client
    Tried to start Rust again > failed again

    So I went back to original settings with noexec and re-ran mount -a.

    I think as well that noexec doesn't apply to SMB, but at least we've tried.

  • Some clever people from suggest trying an iSCSI mount of the drive instead of a classic SMB as a workaround. I didn't know about that protocol and think it's clever. I shall explore this possibility as soon as possible. Gotta move data from this drive away, again first. Will start during the night. Of course I will report back here whatever the issue is.

  • I have no idea if this will offer you any help at all, but I have 2 Raids set up in my OMV, 1 is ext4 and the other is btrfs, I decided to try btrfs purely out of curiosity but having looked at my fstab and compared it to yours something stood out;

    /dev/disk/by-id/md-name-homenas:Volume1 /srv/dev-disk-by-id-md-name-homenas-Volume1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2
    /dev/disk/by-label/Volume2 /srv/dev-disk-by-label-Volume2 btrfs defaults,nofail 0 2
    /dev/disk/by-label/HD-LXU3 /srv/dev-disk-by-label-HD-LXU3 ntfs defaults,nofail 0 2

    The ntfs is a backup usb, now this may or may not be of relevance, also when I created the two file systems I always set the acl option as sambashare again I don't know if that is of relevance.

    As to iSCSI I did test this once in school, you would set up your target on OMV (if that's possible) then your initiator would be on W10, when the initiator connects to the target it will want to format it, which I did to ntfs....but I set mine up purely as a test for backup testing

    EDIT: Just had a look at my OMV and there is an iSCSI plugin....when I tested iSCSI at school I had originally set up a ZFS raid, but the initiator reformatted the target anyway otherwise it can't communicate.

    Second EDIT: W10 has iSCSI initiator already just search in Cortana and it will want to start the service.

    Good luck with it

    Raid is not a backup! Would you go skydiving without a parachute?

    Edited 2 times, last by geaves ().

  • Got my iSCSI drive working.
    Guess what? Rust works ! So that was a good idea. :)

    However, write speeds seem to be quite slow (network interface shows 500Mbit/s) while read speed reach Gigabit.
    I tried Write-through and Write-back but saw no difference.

    Also, if i copy like a 2GB file from my SSD to the iSCSI drive, it copies instantly to the HDD, but disk usage shows 100% and network shows 500Mbit/s upload for the whole time it actually copies the file, then the copy slows down slowly until the transfer is over. RAM usage also increases during the copy, so I assume it's caching into RAM then copies into the disk. I don't really like that since it could result in data loss. Any way to disable it ?

    Relevant screenshot
    SMB > iSCSI copy
    See the read caps right away from SMB protocol, but the write is kind of spread in time, which is quite unpleasant.

  • RAM usage also increases during the copy, so I assume it's caching into RAM then copies into the disk. I don't really like that since it could result in data loss. Any way to disable it ?

    In an word no, I researched this when I did my testing as I was trying to understand ram usage and bottleneck, I bookmarked a page during that research and a final explanation on that page might help you:

    A data transfer could use no RAM buffer if:
    1. programmed I/O (using the CPU) is performed for both the input and the output operations,
    2. the input and output have matching data transfer rates and transfer sizes,
    3. both devices are character-oriented and not block devices. (This would exclude disk drives.)

    then the copy slows down slowly until the transfer is over

    My understanding of this; the final data block is being written/moved/copied from Ram to it's destination.....but then I could be wrong.

    Raid is not a backup! Would you go skydiving without a parachute?

  • @geaves Thanks for your insight.
    Well, i didn't figure out a solution for these poor rates and delayed copies, so i'm gonna stop using iSCSI.
    It was interesting to try though, i'm glad i did it.

    I'll just use SMB until I buy one 2TB or two 1TB SSD(s) to replace this network D:\ drive, it's been a while since I wanted to do that anyways >> All games on SSD, all audio libraries on SSD, will be awesome (and expensive) :)

    Thank you all for your attention, you rock and I wish you the best!

  • I still had this problem when trying to install Dota 2, but I honestly don't remember how I solved the problem, I was helped by a friend who is good at programming and computer. If you need help then I can ask him. I remember that once I tried tommr boost my account, after that they started having problems with Dota again, but fortunately, my friend solved them again. It will surely be useful to many.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!