Upgrade Debian 9 and 4.x

  • Hi,


    after unsuccessful upgrade via omv-release-upgrade.. I am ended upgrade to Debian 9.1..


    But at the moment i have problem with install OMV and incompatible dependence:

    Code
    Následující balíky mají nesplněné závislosti:
    openmediavault : Závisí na: proftpd-mod-vroot ale nebude se instalovat
    E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.


    sources.list


    openmediavault.list


    Code
    deb http://packages.openmediavault.org/public arrakis main
    ## Uncomment the following line to add software from the proposed repository.
    deb http://packages.openmediavault.org/public arrakis-proposed main
    deb http://downloads.sourceforge.net/project/openmediavault/packages arrakis-proposed main
    ## This software is not part of OpenMediaVault, but is offered by third-party
    ## developers as a service to OpenMediaVault users.
    deb http://packages.openmediavault.org/public arrakis partner
    deb http://downloads.sourceforge.net/project/openmediavault/packages arrakis partner
  • The older version of proftpd-mod-vroot in the OMV repo is pinned higher than the version in the stretch repo that you need. So, just do this:


    apt-get install proftpd-mod-vroot=0.9.4-1


    And please change the word stable to stretch in your sources. Otherwise, your system will automatically upgrade to buster when it is released.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ok, and please this one?



  • work on the command line


    the messages are easier to understand


    Probably you have a not reachable packet source
    or
    the key for this source is not available.


    If the latter head to the website where the packet source is referenced and read the instructions there how to obtain the key and add it to your key-files.

  • Code
    Mám:12 https://openmediavault.github.io/packages arrakis InRelease
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fc5bc2b8598>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fc5bc2b8598>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
  • I have seen this as well. Hasn't caused any issue that I can tell but I was going to ask @votdev about it.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This one errors in log every minutes? My issue or global in 4.0?


    Code
    Sep 10 20:26:58 NAS monit[802]: 'collectd' process is not running
    Sep 10 20:26:58 NAS monit[802]: 'collectd' trying to restart
    Sep 10 20:26:58 NAS monit[802]: 'collectd' start: '/bin/systemctl start collectd'
    Sep 10 20:27:29 NAS monit[802]: 'collectd' failed to start (exit status 0) -- no output
    Sep 10 20:27:59 NAS monit[802]: 'collectd' process is not running
    Sep 10 20:27:59 NAS monit[802]: 'collectd' trying to restart
    Sep 10 20:27:59 NAS monit[802]: 'collectd' start: '/bin/systemctl start collectd'
  • I don't have those messages but I have monitoring turned off. Did you tell the upgrade process to overwrite the collectd config? Either way, try:


    omv-mkconf collectd
    omv-mkconf rrdcached


    Then reboot

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • After reboot:



    and journalctl -u collectd


  • Please is possible have OMV extras on 4.x?

    It is on 4.x and has been for a long time.

    Hmm, so after restart same problem:

    No idea. I don't have monitoring enabled on any of my systems.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It helped manually edited according to github.com/openmediavault/open…ab5ff37d7e721048750745f7b (maybe bug in repositary, becuase it was "clean" install from 4.x packages, but there was old files before fix..)

    omv-mkconf monit should fix that as well.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!