Passive mode behind a NAT router returning an internal IP address FTP

  • I cannot access my share outside my home network i have forwarded all the correct ports configured ftp settings in OMV correct but when a client outside the network tried to connect i get unroutable as it is returning its local ip address rather than its external ip address. I have searched many forms but still dont have an answer can anyone please help me before i give up. thanks in anticipation

  • If both the server and client are behind NAT routers, what you are experiencing is a very common problem, regardless of whether the ftp mode is set active or passive. Many routers have an ftp proxy that can be enabled to solve the problem.

    If you want a simple solution that requires only one port to be forwarded and is immune to NAT difficulties, then consider using sftp instead of ftp.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • It doesn't matter what encryption you use for ftp, it's still ftp and uses a separate data port and a separate control port. See:

    Thankyou I understand this but I am not sure how to resolve the problem still

    Try to fill in the masquerade address the external ip or in case you have a dynamic dns.

    I have tried this and it returns the exteral ip address but still does not allow the connection

    thanks for both your help

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!