Teamviewer host not changing password

  • only for curiosity, do you have pihole instaled?.



    I suspect that Teamviewer need some ping or response from internet and my pihole block it and that is the reason, but I can't be sure.

  • No, I dononly for curiosity, do you have pihole instaled?.

    I suspect that Teamviewer need some ping or response from internet and my pihole block it and that is the reason, but I can't be sure.

    No I don't.


    I have installed the Teamviewer plugin on a fresh install of OMV 4.0.17-1 and it works on the go, getting a correct ID from the web panel and accepting incoming connections from my Teamviewer client on Windows.


    So it seems to be some sort of incompatibility with other plugins/services. The problem is that I have so many plugins installed and running on my main OMV build that it will be hard to determine which one interferes with it.


    Plugins


    Containers


  • my plugins are:


    • openmediavault-locate 3.4 all locate plugin for OpenMediaVault.
    • openmediavault-luksencryption 3.0.2 all OpenMediaVault LUKS encryption plugin
    • openmediavault-teamviewerhost 3 all Teamviewer Host plugin for OpenMediaVault.
    • openmediavault-tftp 4.0.3-1 all OpenMediaVault TFTP-Server plugin
    • openmediavault-snmp 4.0.3-1 all OpenMediaVault SNMP (Simple Network Management Protocol) plugin
    • openmediavault-webdav 4 all OpenMediaVault WebDAV plugin.

    I have a virtual (test) enviroment to test your aproach, so my next probe can be install teamviewer alone and check if works


    PD: in my test enviroment , teamviewer actually do not work, but I install first the 6 plugings that have in my primary NAS, and never check to install teamviewer the first, so this night i have a response for you.

  • I do a new fresh install and then update it, next I install Omv-extras, and activate teamviewer repro, install teamviewer and still no work, so it's not a conflict with plugins, at leats on my side / test enviroment.


    PD: because my test enviroment use DHCP for images, the test image use pihole as default DNS server, so the only test that this night I can do is to change image config to use fixed IP and fixed DNS= 8.8.8.8 to test again.

  • new test, same that previous, but use 8.8.8.8 as DNS, still no luck, so in my side is not pihole or some plugings the cause.


    Do you do some test in your side?.

  • Hi!
    I have installed the Teamviewer plugin and it doesn't work also.
    Actually the teamviewerd is running:

    But I can't connect remotely - Teamviewer client says that Teamviewer isn't active on the remote computer.
    I joined my OMV NAS to teamviwer account (using teamviewer setup via SSH), but it stays offline in teamviewer client.
    Than I trying to do teamviewer setup again, I've got message that my system is already registered. And it becomes online on the Teamviewer client list at that moment, but it's impossible to connect anyway.
    It looks that teamviewerd doesn't connect to teamviewers' servers:

    Code
    root@droid:~# netstat -ntap | grep teamviewer
    tcp 0 0 127.0.0.1:5943 0.0.0.0:* LISTEN 5507/teamviewerd

    No idea what to dig next.

  • same problem here and still no luck ( and I search deeper in google, but no useful answer), sorry, if you finally find a solution , please remember to share here.

  • raulfg3
    I do have read this topic, and I spent few days searching the solution. But not successfully also.
    But I guess I found the possible core of that problem, because the netstat output on the system with operational teamviewer looks like this:

    Code
    user@home_machine:~$ sudo netstat -ntap | grep teamviewer
    tcp 0 0 127.0.0.1:5941 0.0.0.0:* LISTEN 20351/teamviewerd
    tcp 0 0 192.168.1.100:49333 176.223.198.114:5938 ESTABLISHED 20351/teamviewerd


    In my case I found there is no connection teamviewerd to Teamviewers servers:

    Code
    root@droid:~# netstat -ntap | grep teamviewer
    tcp 0 0 127.0.0.1:5943 0.0.0.0:* LISTEN 5507/teamviewerd

    Now I'm trying to find the reason of connection absence.
    May be somebody here has ideas about...

  • good to know i do some test too and post my result here.



    sorry no netstat on my system:


  • sorry no netstat on my system:

    netstat is old but apt-get install net-tools will install it.
    $ sudo netstat -tupln | grep team
    tcp 0 0 127.0.0.1:5939 0.0.0.0:* LISTEN 14099/teamviewerd


    Use ss which should already be installed on your system:
    $ sudo ss -tulpn | grep team
    tcp LISTEN 0 128 127.0.0.1:5939 *:* users:(("teamviewerd",pid=14099,fd=14))

    Now I'm trying to find the reason of connection absence.
    May be somebody here has ideas about...

    Your system is listening. This would be a good question for the teamviewer people. I saw your github issue but there is nothing I can do to fix the plugin if the service is listening.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ok, net-tools installed:



    my install:

    My hardware is HP510 on signature.

  • ok, net-tools installed:

    You didn't need to install net-tools. Your system is listening on the right port. Not sure what else to say other than ask on the teamviewer forum.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron
    At my view, Teamviewer daemon have to initiate connection to Teamviewers servers (something like server19408.teamviewer.com) for handshake, ID assignment, tunnel establishment, etc., before teamviewer client will get possibility to connect to target system.
    Otherwise it will be impossible to connect remote system via internet thru NAT, routers, etc...
    On this netstat output:

    Code
    root@RDNS:~# netstat -ntap | grep teamviewer
    tcp 0 0 127.0.0.1:5939 0.0.0.0:* LISTEN 16170/teamviewerd

    we have only localhost listening for loopback purposes only.
    There is no any other connection necessary for tunnelling between remote an local systems via Teamviewers servers.
    That is the problem I guess.
    Other thing, I cannot connect my remote system directly in the same local network, but teamviewer software allowed direct connection in the same local network, for Windows version at list.
    I didn't check that you are the author of openmediavault-teamviewerhost plugin, I'm sorry for any possible inconvenience for you in case my issue opening on Github.
    And you are right - that's the question for teamviewer support mostly.

  • we have only localhost listening for loopback purposes only.
    There is no any other connection necessary for tunnelling between remote an local systems via Teamviewers servers.
    That is the problem I guess.

    My test system is working with only localhost listening. Below is the output with and without being connected to a teamviewer client from the internet.


    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • No idea how it can be working without established connections.
    Perhaps it happened because you cut off other connections from netstat output by using -l parameter.

    It is connected.
    tcp 0 0 192.168.1.18:53690 162.250.3.6:5938 ESTABLISHED 14099/teamviewerd

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • raulfg3
    Teamviewer team declaring about headless instalation mode
    Installation via ssh (headless mode)
    After installing the package via ssh, on a machine with no monitor attached and no X server running, you have to find a way to connect.
    You could set a password and get your TeamViewer ID via command line, but the recommended way is to assign the device to your account. To do this, run setup.
    How-to-install-TeamViewer-Host-for-Linux
    And System requirements nothing says about X server.
    But anything can happen...

  • still no luck, I connect a keyboard and a monitor to my headless HP510, and still no luck same error.


    NO ID.


    PD: If I run setup from shell:


    Code
    root@RDNS:~# teamviewer setup
    El demonio de TeamViewer no está en ejecución; la instalación no puede continuar. Active el demonio
    de TeamViewer antes de invocar la instalación.
    root@RDNS:~#




    and teamviewer info:



    and if I restart daemon, still no ID:


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!