docker CE issues with plugins and config problems

  • Hi,

    I am running 4.0.8-1 Arrakis and have the following problems

    the docker GUI does not let me pull any images, but CLI works fine, after pulling with CLI they do show up in the docker gui plugin.

    SOLVED: adding a tag name doesn't let me pull image, without tag no issue.

    Then i have also an issue with transmission, before the upgrade i have three directories configured with worked for transmission


    Volumes and Bind Mounts for transmission i am able to do the following

    /media/fac202db-49d5-4dba-92b0-bee63109d140/bittorrent/downloads /downloads
    /media/fac202db-49d5-4dba-92b0-bee63109d140/bittorrent/incomplete /incomplete

    but.... i am not able to set the watch directory it simply doesn't let me choose it , i have changed permissions as well with no success , is that a known issue?

    I would like to set

    /media/fac202db-49d5-4dba-92b0-bee63109d140/bittorrent/watch /watch

    When i do not select it and start up i see that its using /watch and /config but i don't know how to use that and where its located.
    Also i am not able to set the config path different shows up as /config.

    I'm not able to find a configuration example for linuxserver/transmission in docker gui plugin did anyone made one?


    To be able to use the directories i needed to choose one directory higher in the path and then do the bind that worked.

    Binds": [

    UPDATE: another issue i have is when i create a image with docker on CLI it shows up in the GUI but i am not able to start it from the GUI only from CLI the stop and running state does show up in the GUI when refreshed but stat/stop/restart is greyed out.


    root@nas:/home# docker create \
    > --name=medusa \
    > -v /home/docky/.config/medusa:/config \
    > -v /media/fac202db-49d5-4dba-92b0-bee63109d140/bittorrent/downloads:/downloads \
    > -v /media/fac202db-49d5-4dba-92b0-bee63109d140/video/tv_series:/tv \
    > -e PGID=100 -e PUID=1008 \
    > -e TZ=CET \
    > -p 8081:8081 \
    > linuxserver/medusa
    Unable to find image 'linuxserver/medusa:latest' locally
    latest: Pulling from linuxserver/medusa
    fa3664431217: Already exists
    1fc945f30eb3: Already exists
    b7851c471e02: Already exists
    3a98b322e46b: Pull complete
    3b1b976fb033: Pull complete
    daea6fc44894: Pull complete
    Digest: sha256:43b07666f745872baa8311470e0bfbc384a768a7fc4995c094714f69e3db6dde
    Status: Downloaded newer image for linuxserver/medusa:latest

    root@nas:/home# docker ps -a
    bf9f2ba0a270 linuxserver/medusa "/init" 12 minutes ago Created medusa
    253fe437ee22 linuxserver/radarr:latest "/init" About an hour ago Up About an hour radarr
    a9f69fb393bc linuxserver/libresonic:latest "/init" 2 hours ago Up 2 hours libresonic
    0feb5a62c9e9 hello-world "/hello" 4 hours ago Exited (0) 4 hours ago pedantic_bohr
    root@nas:/home# docker start -ai bf9f2ba0a270
    [s6-init] making user provided files available at /var/run/s6/etc...exited 0.
    [s6-init] ensuring user provided files have correct perms...exited 0.
    [fix-attrs.d] applying ownership & permissions fixes...
    [fix-attrs.d] done.
    [cont-init.d] executing container initialization scripts...
    [cont-init.d] 10-adduser: executing...

    _ _ _
    | |___| (_) ___
    | / __| | |/ _ \
    | \__ \ | | (_) |
    |_|___/ |_|\___/

    Brought to you by
    We gratefully accept donations at:
    User uid: 1008
    User gid: 100

    [cont-init.d] 10-adduser: exited 0.
    [cont-init.d] 30-config: executing...

    [cont-init.d] 30-config: exited 0.
    [cont-init.d] done.
    [services.d] starting services
    [services.d] done.

    It would be great if i can create on CLI and then use the GUI as i'm not able to get the pull from GUI and also can not use the paths i would like.

    Till now the whole plugins docker thing has been a bad experience, i just notice i also can not see my tv shows directory in medusa can not select it this while i have specified the paths.

  • Its not solved, yes i am able to install now images but ..... i am struggling with basic config issues which frustrates me.

    Somehow i can not get sickrage or Medusa to work web server doesn't open op 8081 and the cpu of the dock spikes to 100% when it runs.
    So i gave up on these don't know if this is 4.x related as i never had problems with the normal plugins.
    So i decided to give sonarr a try downside is to get some good indexers Jackett is needed, so i needed to install and configure jackett as well.

    Now i finally am at the point after a whole day troubleshooting and fixing several errors, that i have images running but transmission is not picking up anything from watch folder.
    Big problem here is that you need to configure all the paths in docker over and over

    Can someone tell me if its possible to check in some log why transmission is not picking up torrent files in watch folder, is it good configured what to check?
    Where can i debug docker images if something is not working like webserver sickrage, watch folder transmission etc

    Starting to dislike dockers as i do not seem to be in control, i have more then 20 years of enterprise unix experience and i feel helpless :( is the answer will be better use another torrent downloader then please point me in the right direction.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!