rrd problem?

  • Hi I am seeing this system logs reporting all the time. How can it be stopped?


    May 4 10:03:12 openmediavault collectd[1120]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)

  • In command line, via putty or whatever, do the following:


    omv-firstaid (hit ENTER)


    Then there is an option to reset the graphs, new feature in OMV 4.x. Do that and see if the error goes away. I suspect rrdcached is not running correctly. This should fix it.

  • Then there is an option to reset the graphs, new feature in OMV 4.x. Do that and see if the error goes away. I suspect rrdcached is not running correctly. This should fix it.

    Thank you again!
    Your comments clued me in on this issue. After I tried omv-firstaid thing, the log showed 'flushing old values' and 'rotating journals' and then it started to work correctly so I disabled it again in effect. :)

  • I have same problem with rrdcached, with same log as few posts above:

    Quote from canadavault

    May 4 10:03:12 openmediavault collectd[1120]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)

    I don't have /var/run/rrdcached.sock created, when monitoring is running. I installed my OMV in december, so it should be up to date, and yet I don't have option to reset graph in omv-firstaid. What can I do to have monitoring working?
    Thanks in advance for help!

  • Only if you updated.


    Current version is 4.1.17-1


    Have you tried to disable and enable monitoring?

    My version is 4.1.17-1.
    Yes, I tried restarting monitoring several times. I also tried to erase rrd database, no effect.

  • I'm getting this on a new install to an ARM device. Every time I "apply", it ends with a message, "Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details."


    journalctl shows the message the OP quoted, many, many times.


    Then the yellow banner appears again to say I must apply changes.


    Using stretch-openmediavault-rock64-0.7.11-1075-armhf.img.xz on a Rock64. HDD is formatted, SMB shares defined, but I can't see the shares yet from another computer on the same network. Still working on it...

  • Problem corrected.


    I had followed the startup guide and set a static IP outside the router's DHCP range. But at the same time, the router showed its DHCP assigned IP for the OMV server. The router can "reserve" an assigned IP for a device, so I used that and undid the OMV static IP setting. I think that got SMB working, which it is now.


    This cable provider modem/router often mixes up device names when listing connected devices. A curiosity.


    I also rebooted the OMV server. No more error messages on "apply".

  • @tekkb
    Today I upgraded system again.
    I still have my issue with monitoring not working and this message in syslog:

    Code
    Feb 17 20:08:44 albert collectd[2625]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)


    My system information:

    If you need file with full system info, I can provide it.
    I cannot reset graph via omv-firstaid. See below my omv-firstaid picture:
    firstaid.png
    There is one more option, to submit report to system admin.
    It there any other command, that I can use to reset graphs? I already tried omv-mkrrdgraph, but it gives me ERROR: Unable to connect to rrdcached: No such file or directory many times, and exits.


    I would really appreciate any help.

  • I think I found the cause of the problem (not the root caus unfortunately) and found a workaround to get rid of the error and get the graphs working. I did have the same problem:


    Feb 17 23:33:07 storage collectd[5812]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory


    I discovered that collectd wants to connect to a unix socket created by rrdcached. rrdcached is not started for an unknown reason. systemd fails to start it. I started it manually with the correct socket path and it works for me.


    /usr/bin/rrdcached -l unix:/var/run/rrdcached.sock


    After that I restarted collectd (not sure if it was required) and errors are gone, graphs start to work.


    Now I just have to find out why rrdcached does not start correct by systemd or init script.

  • I have described in my previous post how to start rrdcached manually. I found a thread on this forum where someone (racoonsn) found the solution. Cause of this problem is a fake startupscript in debian. The fake startupscript was used during installation and should be replaced by the REAL one. This replacement has failed for some reason, but you can do it manaually once, then reboot your system and rrdcached starts fine.


    See this thread to read racoonsn fix: https://forum.openmediavault.o…3-rrdcached-plugin-error/


    Solution is to replace a fake startup script with a real startup scripts. The real file already exists, you just have to copy it over the fake one. They both exist in the /sbin directory.


    Code
    ls -al /sbin/start-stop-daemon*
    -rwxr-xr-x 1 root root 94 Feb 14 23:12 /sbin/start-stop-daemon
    -rwxr-xr-x 1 root root 31848 Jun 26 2018 /sbin/start-stop-daemon.REAL

    Content of fake script, which is active by default:

    Code
    cat start-stop-daemon
    #!/bin/sh
    echo 1>&2
    echo 'Warning: Fake start-stop-daemon called, doing nothing.' 1>&2
    exit 0

    Now I just copied the REAL script (binary) over the fake script.


    Code
    cd /sbin/
    cp start-stop-daemon.REAL start-stop-daemon

    Reboot you omv installation and rrdcached starts automatically. Errors are gone and graphs start to work.

  • Solution is to replace a fake startup script with a real startup scripts. The real file already exists, you just have to copy it over the fake one. They both exist in the /sbin directory.

    Thanks! This help me to solve the problem on Debian 9.9 running 4.1.8.2-1 (Arrakis).

  • Hi together,


    I'm running in the same problem, but unfortunately I dont't have any start-stop-daemon.REAL in my sbin directory :/


    root@xxxx:/sbin# ls start-stop-daemon
    start-stop-daemon
    root@xxxx:/sbin#


    Any advice :/...? Or would someone be so kind to upload the file for me?
    Thanks in advance!

  • Привет вместе,


    У меня та же проблема, но, к сожалению, у меня нет start-stop-daemon.REAL в моем каталоге sbin

    Try this: apt-get install dpkg --reinstall

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!