How to restore from an omv-backup?

  • If you did not install systemrescuecd from the OMV-Extras page, Kernel tab, then you need to do that first.


    Then you can go back to the same page and press the 'Reboot to SystemRescueCD Once'' button or you can reboot normally and when you are in the kernel list screen, scroll down to the end and select 'SystemRescueCD' from the menu. Be careful in there.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Huh, I don't noticed kernel tab. Thanks.


    EDIT


    Is something wrong with SystemRescueCD servers or I am out of luck.


    I can't download iso


    Blank dialog before and after pressing start download


    1.png

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

    Edited once, last by gett ().

  • Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-4.19.0-5-amd64
    Found initrd image: /boot/initrd.img-4.19.0-5-amd64
    done

    That is doing the correct thing assuming the ISO had already been downloaded. What is the output of: ls -al /boot/*.iso

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This is the output:


    root@ServidorNas:~# ls -al /boot/*.iso
    -rw-rw-rw- 1 root root 0 Dec 27 11:32 /boot/clonezilla-live-2.6.0-37-i686-pae.iso
    -rw-rw-rw- 1 root root 0 Dec 27 11:36 /boot/systemrescuecd-6.0.3.iso

  • This is the output:

    So, it looks like everything worked. Not sure why you aren't seeing output in the web interface. Do you have the entries in your grub menu when rebooting?

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi have the grub menu, but what I saw is that the file size for both ISO files are 0. I think the problem is there.

    Oops. missed that. That happens when the wget command specifies an output file (which it creates) but fails to download probably due to a dns or network issue.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Here is a basic restore procedure using dd for the same hard drive but a change went bad:

    • Boot systemrescuecd - if you installed the iso from omv-extras, it will be in your grub menu.
    • Mount your data drive - example: mount /dev/sde1 /mnt/backup
    • Figure out where your backup file is. dd uses the .dd.gz extension - example: /mnt/backup/omvbackup/backup-omv-07-May-2018_10-36-31.dd.gz
    • Figure out what your OS drive root partiton is. Don't get this wrong! - example: /dev/sda1
    • Restore the files - example gunzip -c /mnt/backup/omvbackup/backup-omv-07-May-2018_10-36-31.dd.gz | dd of=/dev/sda1 bs=1M status=progress
    • reboot

    Hi. I hosed my system in the process of trying to upgrade from OMV 4 to OMV 5. Thankfully I have backups, but I'm having trouble restoring them. I have the following files :

    Code
    -rwxr-xr-x 1 oli oli 1171 Apr 18 00:00 backup-omv-18-Apr-2020_00-00-02.blkid
    -rwxr-xr-x 1 oli oli 10508875462 Apr 18 01:51 backup-omv-18-Apr-2020_00-00-02.dd.gz
    -rwxr-xr-x 1 oli oli 373 Apr 18 00:00 backup-omv-18-Apr-2020_00-00-02.fdisk
    -rwxr-xr-x 1 oli oli 446 Apr 18 00:00 backup-omv-18-Apr-2020_00-00-02.grub
    -rwxr-xr-x 1 oli oli 512 Apr 18 00:00 backup-omv-18-Apr-2020_00-00-02.grubparts
    -rwxr-xr-x 1 oli oli 1251 Apr 18 00:00 backup-omv-18-Apr-2020_00-00-02.packages
    -rwxr-xr-x 1 oli oli 739541 Apr 18 00:00 backup-omv_u-boot-18-Apr-2020_00-00-02.tar.bz

    I tried the method above, but for some reason, the dd image is bigger than my partition by 1792*512 bytes, so it gets truncated and the filesystem is corrupted. fsck is able to fix the numerous errors but I don't want to trust nothing got broken.

    Code
    Disk /dev/mmcblk0: 29.7 GiB, 31914983424 bytes, 62333952 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0xe8f118bf
    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk0p1 8192 61710591 61702400 29.4G 83 Linux

    I tried putting in directly on the device instead of the partition but again it doesn't work (no partition table):

    Before I mess things up even more, I wanted to double-check with the forum users what they think I should do. I was thinking of restoring the grubparts, resizing the partition to accomodate the dd image and try restoring that.


    Does anyone have a better idea?


    Thanks.

  • Hi,

    So sorry for my newbees questions but..


    i'm in this case, SSD with OMV crashed (file system was corrupt), i'm saying: " no problem i have install before the backup OS plugin from ryecoaaron and i have one good backup " (i have juste configure the backup without test a restore, big mistake....)

    So after read and read many post.....i'm sorry to ask you some help.


    The backup method i have choose is DD (not all disk but only OS space used) i have choose this, if i have to restore on a smaller disk.

    So now i have a new SSD of 120GB (the old it's a 128GB). My backup GZ size is 84GB ( with .grup, .blkid, .fdisk, .packages, .ddfull.gz etc)


    I have test to make restore with graphical methode (with clonezilla) but GZ it's no recognized . I have read something about to just to mount source disk where is the image backup and make 2 line of command. ... So complicated for me to this

    Now my backup it's securised on a external USB (ntfs format)


    Can you give me the exact procedure to do restore please? exemple:

    1/ re-install omv on the new disk (correct?)

    2/ install extra plugin

    3/ install rescueCD

    4/ type the first line commande : mount /dev/sdx (label forder) etc

    5/etc....

    thanks<3<3

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!