Raspberry Pi 3 - Error installing Docker

  • Hi,


    I was able to install the docker gui plugin using rodon's suggestion. But when I enabled the plugin and tried to search I got the below error,


    Error #0:
    OMV\Rpc\Exception: Invalid RPC response. Please check the syslog for more information. in /usr/share/php/openmediavault/rpc/rpc.inc:186
    Stack trace:
    #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Docker', 'getContainers', Array, Array, 3)
    #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #2 {main}


    Syslog:
    raspberrypi omv-engined[6922]: PHP Fatal error: Uncaught Error: Call to undefined function curl_init() in /usr/share/omvdocker/Utils.php:63#012Stack trace:#012#0 /usr/share/openmediavault/engined/rpc/docker.inc(319): OMVModuleDockerUtil::doApiCall('http://localhos...')#012#1 [internal function]: OMVRpcServiceDocker->searchImages(Array, Array)#012#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#012#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('searchImages', Array, Array)#012#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'searchImages', Array, Array, 1)#012#5 {main}#012 thrown in /usr/share/omvdocker/Utils.php on line 63

  • My fix worked on my pi3b+ the night before I posted.


    I'm trying to setup the docker plugin on a separate pi3b today and am getting the same rpc errors. I seems as though something has changed with the buster php packages or omv since my original post.

  • Warning: I take no responsibility for this making your system unstable, but this work-around worked for me...

    NO NO NO NO!!! You will basically end up upgrading your system to Debian 10. Yes, this may "fix" the issue but it is avoiding the problem. I am sorry I am not home to try to fix the issue but this is the wrong solution.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I'm having the same problem with docker, OMV and my raspberry-pi.


    It must be something with a package installed from the RPi repo because I just installed the docker plugin on my renegade board (arm64) earlier today with no problems.


    Thanks for checking on this thread, ryecoaaron. What can we do to help track down or figure out if it's a RPi repo package that's causing the problem?

  • I'm having the same issue.. maybe the repo is dead or something?


    I did 4 times a fresh install and got the same error on docker. Really annoying..

    Yeah, I did the same thing. I thought I did something wrong. I'm at a loss on how to troubleshoot this type of issue.


    I don't know how to figure out what package is having a problem. If I did, I could then bring it to the responsible party's attention in order for them to look at the issue.

  • So, no one has any clue on what we need to do?


    I regreated updating it to OMV 4... the 3.0.99 was working like a charm... but I dont have anylonger the iso for this version to reinstall it... does any one have it?

  • I am currently still testing but I think i found the solution. Not a great one though.
    Comment out security update entry from your etc/apt/sources.list. It will allow to install php7.0-curl of the correct version instead of the 7.0.30 it wants.
    Once docker is installed, return that entry back to working order


    EDIT:
    Yup, removing security updates entry from the sources.list allows docker to install.
    Problem was that php-curl wanted php7.0-curl but for some reason apt wanted to install 7.0.30 instead of 7.0.27 which is the version of php-common that is already installed in omv


  • Hello Wolf_vx.


    I tried that but still no luck.


    I tried to install php7.0-curl but I got the following error:


    $ sudo apt-get install php7.0-curl
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    php7.0-curl : Depends: php7.0-common (= 7.0.30-0+deb9u1) but 7.0.27-0+deb9u1 is to be installed
    E: Unable to correct problems, you have held broken packages.


    Then I tried to install the php7.0-common
    $ sudo apt-get install php7.0-common
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    php7.0-common is already the newest version (7.0.27-0+deb9u1).
    php7.0-common set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


    Any clue? I'm a complety newbie on Linux.


  • No luck here as well. I attached my sources.list, gui output and ssh install for reference. Also a bit of a newbie

    Have both of you done apt-get update?


    How I did the last test install:
    1. Flash fresh image to SD card
    2. Wait till it starts
    3. Update to latest packages
    4. Restart
    5. Comment out security and backport lines (2 bottom ones) from sources.list
    6. apt-get update
    7. Enable docker repo
    8. Install docker
    9. Profit


    EDIT:
    You can test if you did things correctly by using apt-get install php-curl. If that doesn't ask to accept that new packages will be installed, you still haven't done something with apt or sources.
    You need to apt-get update to make sure it forgets about security patches.

  • Performed the steps above exactly and getting the same errors.


    Attaching my sources and install outputs.

  • Output of apt-cache php7.0-common php7.0-curl and apt-get install php-curl -t stretch-backports attached.

    I forgot the word policy after apt-cache. So, you output didn't help much. Can you re-run it? I wouldn't bother trying to install it yet.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!