thumbdrive boot disk shows size of 16GB but filesystem only shows 2.81GB

  • First time poster and new to omv, i did my install to a 16GB sd card after following a guide found here on this site for formatting and testing. The card verified good so did my fresh install and all went good with install, but after using for a couple days and adding plugins i noticed that i could not run update check anymore. Searched this site and and looked around in the install and found that my filesystem on the boot drive was full at only 2.81GB even though it is a 16GB card. I also noticed that when i look at disks it shows as /dev/sdc 14.84GB but under filesystems it shows as /dev/sdc1 2.81GB.
    Hope someone can help me out, I looked at the card in gparted and saw that it had 2 partitions the first was only the 2.81 GB as sdc1 and the second was at 11.80GB or so but it said that partition was the swap partition. I could not shrink one and enlarge the other, it would not let me do that. Thanks in advance to anyone who can help :thumbsup:

  • Double check your partitions. Swap should be the smaller of the two. I can't imagine that an OMV install would get those backwards.

    However, if you are sure your swap is the larger of the two partitions, you can delete it and grow the smaller one to be 11.8GB and then create a new swap partition using the remainder of the disk.

    I have 16GB of RAM in my OMV machine, so I am able to run without any swap at all.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Thanks for reply, and yes the swap was the bigger partition. I also tried like you said to delete swap partition and grow first partition but gparted would not let me grow that first partition. It was like it was stuck at that size. I can post any logs if need to. I also have 12GB of Ram in this system.

  • Where are you running gparted when you try to do this? All partitions must be unmounted before you can resize them.

    I'd really like to see a screenshot of gparted.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I am doing it on a laptop running kde neon. I will shutdown my omv and pull card and put it in gparted on laptop so i can get a screen shot. Will take a few minutes,1.jpeg2.jpeg3.jpeg

    I have never seen that.. Weird.

    I would probably just start over since you probably don't have a ton of time invested in such a new install. Did you put an image on the card (like for an arm device) or did you install to the sdcard from an ISO?

    Something definitely went haywire..

  • then create a new swap partition using the remainder of the disk

    Just three general remarks:

    • There is no need for a swap partition since kernel 2.6 (that's now over 15 years ago). See last paragraph of:
    • Swap on SD card is not a great idea since common SD cards are slow as hell if it's about random IO. Some info, more info
    • If the system is running low on RAM (less than 2GB) activating zram is a way better idea than swap on slow storage
  • this is what the install did on my thumbdrive, i was using a dvd and and only had my thumbdrive plugged in. when i put a harddrive in during install and still pick the thumbdrive for place to install it fails making the partition on thumbdrive every time. so i just tried with only thumb plugged in and i get what you see in the pics. Very strange stuff hope to get it working, i have 12gb of ram in system running on an i5 3340 processor. I will burn a new dvd maybe it is corrupt.

    Update I found that the omv installer was looking at my sd card as a mass storage device and was making a root partition of only 3GB approx and a swap partition for the other 12GB on the sd card. It was not giving me an option to change the partitions so i ended up doing a netinstall of debian first and set it to use the whole sd card as root. I hope this works and will update this post to let others know. Thanks

  • Well what a day i did get it to work with Debian first but then broke it again. I must have done something out of order cause after a reboot ip changed to 172.17.something docker.So i started over and was determined to get it working using the install DVD and my sd card which i had in a usb micro sd card reader. But i could never get it to use the full capacity of the card, it always made a 3gb partition for the system boot drive and a 12gb swap. I was able to delete the swap and extend the system boot drive to full size of card using cfdisk in a terminal but it still showed as a 3gb partition when i put back into the machine i want to use. This is the strangest i think I've ever seen. So after doing this all day long i finally gave up and just used a spinning harddrive as a boot drive. Just hated to waste my smallest 300gb drive for a system that only needs 8-16gb to run. I tried multiple thumb drives and sd cards all to no avail.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!