Docker with nextcloud help

  • Hi
    I followed the tdl life video to install nextcloud.
    all seemed to go good, but when i log in and check overview i have some recommendations to fix.


    There are some warnings regarding your setup.

    • The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.


    • Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.
    • Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.

    Some columns in the database are missing a conversion to big int. Due to the fact that changing column types on big tables could take some time they were not changed automatically. By running 'occ db:convert-filecache-bigint' those pending changes could be applied manually. This operation needs to be made while the instance is offline. For further details read the documentation page about this.[*]filecache.mtime
    [*]filecache.storage_mtime
    [/list]Can someone point me in the right direction on how to edit what needs to be edited.

  • Its possible either way.
    1. Option: Login in to NC via the GUI with an admin-account. Install the occ-web app and execute the command there.
    2. Option:


    There the command would be sudo -u abc /config/www/nextcloud/occ db:convert-filecache-bigint

  • Hi!


    I was also struggling with the occ commands while moving my Nextcloud from version 15.0.14.1 (local) directly to version 18.0.3.0 in to docker (linuxserver/nextcloud). After rsync the /data, /config, /apps/deck folder and uploading the mysql DB backup into the linuxserver/mariadb, I was not able to run any occ commands inside the docker. After logging into my Nextcloud docker

    Code
    docker exec -it Nextcloud bash

    trying to run occ ended up with following issue

    The solution for me was to alter the command as follow:

    Code
    root@omv:/$ sudo -u abc php7 occ status
    sudo: setrlimit(RLIMIT_CORE): Operation not permitted
    - installed: true
    - version: 18.0.3.0
    - versionstring: 18.0.3
    - edition:

    Before executing you have to change to the respective directory cd /config/www/nextcloud/


    Maybe it will be for someone of help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!