Fdisk problem

  • Hello,
    I booted up a Debian Live and I deleted the system partition to resize it. After creating a new partition with the same sector to start but not the same to end (to have extra space for OMV to use it for share) I saved my changes with 'w' I ran 'sudo partprobe' and tried to run 'sudo resize2fs /dev/sda' but the following error occurs:error.jpg

  • Thank you! Now I know how not to resize the system partition.

    Typically I use GParted, so this is no problem for me. Still, good to know!

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • The image is wrong. While you can resize partitions this way, it is dangerous. I would never use fdisk to do this unless you really know what you are doing. You have to make sure that there is no data in the part of the partition that you are removing. gparted does this for you. Using parted from the command line (if you can't get gparted working) is a much better option - https://www.tecmint.com/parted…ue-linux-disk-partitions/

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!