Losing DNS settings whenever, I install a portainer and docker.

  • Hi,


    I went thru the process to install OMV5 using raspbian lite and I a minor issue. So I installed raspbian lite, OMV 5, changed the ip address, and then installed docker without issues. Then I went to install portainer and it says that there is an dns error. Sure enough, I checked the /etc/resolv.conf and there is no name servers there. So I manually added google's dns server and sure enough I was able to install portainer. However, in that process, it blanked out the resolv.conf again. Is there somewhere in OMV5 where I can put in the dns servers because the setup doesn't have this. Thanks.

  • Is there somewhere in OMV5 where I can put in the dns servers because the setup doesn't have this.

    System | Network | Interfaces | select interface, press Edit, scroll down to Advanced settings | Enter DNS Servers separated with commas.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • System | Network | Interfaces | select interface, press Edit, scroll down to Advanced settings | Enter DNS Servers separated with commas.

    Thanks. Didn't realize that this is all the way in the bottom.

    Are you talking about a portainer OMV plugin or a Debian package? If this issue is caused by a plugin, then the plugin should take care about the systemd-resolved service, please.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!