Secure FTP

  • Hi, Hopefully someone can help.

    I need to set up an FTP server, I could do with the connection being encrypted.

    So I have installed OMV on a spare Raspberry Pi that I had and have configured it with SMB so that I can get files onto it and FTP so that a remote party can also grab files.

    At the moment I am doing all of this within my home network so there is no firewall in the way.

    If I set up FTP and log in with my user it works, I can access files and upload new ones, however if I enable SSL/TLS connections I get a message saying the directory listing cannot be retreived.


    this is the log from filezilla:


    Status: Connecting to 192.168.1.133:21...

    Status: Connection established, waiting for welcome message...

    Status: Initializing TLS...

    Status: Verifying certificate...

    Status: TLS connection established.

    Status: Server does not support non-ASCII characters.

    Status: Logged in

    Status: Retrieving directory listing...

    Command: PWD

    Response: 257 "/" is the current directory

    Command: TYPE I

    Response: 200 Type set to I

    Command: PASV

    Response: 227 Entering Passive Mode (192,168,1,133,200,65).

    Command: LIST

    Response: 150 Opening BINARY mode data connection for file list

    Response: 425 Unable to build data connection: Operation not permitted




    Any help would be appreciated :)



  • If I set up FTP and log in with my user it works, I can access files and upload new ones, however if I enable SSL/TLS connections I get a message saying the directory listing cannot be retreived.

    Hi,

    I have exactly the same problem. As soon as I activate the SSL / TLS connections, Filezilla cannot recover the directories (with the same log as David).

    On the other hand everything works well with WinSCP on a Windows machine.

    I can't reproduce the same configuration with Filezilla?

    Ideas ?

  • Hi.

    I had the same problem. Found an entry in the proftpd forum that it is a proftpd behaviour/problem. You should acticvate the option "no session reuse required" a try. This option is in FTP -> SSL/TLS. For me it works after that.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!