NextCloud no AppStore

  • Hello,


    I followed the instructions of Techno Dad's video:

    in order to install Nextcloud via docker in OMV. At the moment I have access to nextcloud and can reach it from various devices. My problem is that i cannot install apps because there is no Icon to click on and recommended Apps in a pop up window (DesktopClient) do not react when clicked on.


    The problem is already discussed and solved here: https://help.nextcloud.com/t/appstore-is-empty/65078/4 Apparently it has to do with a timeout value, which has to be increased.

    However I do not know where to find the file in my setup (Raspberry Pi with OMV + Docker + Portainer + the Stack with Nextcloud)


    Thanks a lot!

  • I found the .php files to change the timeouts but changing them did not help with my problem. Still no Appstore. I also created a new user "pi" in the case that there are "rights issues". Furthermore the appstore directory exists but is empty. I also tried to log in with nc_admin or admin but those users dont exist, which was to be expected.


    I linked a screenshot of the apps page.


    Any more ideas?




  • I am also having the same problem in my installation of nextcloud. I cannot install any app from the nextcloud App store.


    I did some digging around and i found out that the solution is this:


    <<Open your config/config.php file in the root of the NC installation and verify/add this line:

    'appstoreurl' => 'https://apps.nextcloud.com/api/v0',>>


    however, i have no idea how to do it, i am illiterate with linux.


    Can anyone tell/write how will i be able to add this line to the config.php file?

  • I have used the following script under docker compose and i cannot find where the configuration file is:


    version: '3'


    services:


    proxy:

    image: jwilder/nginx-proxy:alpine

    labels:

    - "com.github.jrcs.letsencrypt_nginx_proxy_companion.nginx_proxy=true"

    container_name: nextcloud-proxy

    networks:

    - nextcloud_network

    ports:

    - 80:80

    - 443:443

    volumes:

    - ./proxy/conf.d:/etc/nginx/conf.d:rw

    - ./proxy/vhost.d:/etc/nginx/vhost.d:rw

    - ./proxy/html:/usr/share/nginx/html:rw

    - ./proxy/certs:/etc/nginx/certs:ro

    - /etc/localtime:/etc/localtime:ro

    - /var/run/docker.sock:/tmp/docker.sock:ro

    restart: unless-stopped


    letsencrypt:

    image: jrcs/letsencrypt-nginx-proxy-companion

    container_name: nextcloud-letsencrypt

    depends_on:

    - proxy

    networks:

    - nextcloud_network

    volumes:

    - ./proxy/certs:/etc/nginx/certs:rw

    - ./proxy/vhost.d:/etc/nginx/vhost.d:rw

    - ./proxy/html:/usr/share/nginx/html:rw

    - /etc/localtime:/etc/localtime:ro

    - /var/run/docker.sock:/var/run/docker.sock:ro

    restart: unless-stopped


    db:

    image: mariadb

    container_name: nextcloud-mariadb

    networks:

    - nextcloud_network

    volumes:

    - db:/var/lib/mysql

    - /etc/localtime:/etc/localtime:ro

    environment:

    - MYSQL_ROOT_PASSWORD=B9OzOHr5w9DMNh2jPbJJ

    - MYSQL_PASSWORD=p6lAlEupyDj2CEOubqgb

    - MYSQL_DATABASE=nextcloud

    - MYSQL_USER=nextcloud

    restart: unless-stopped


    app:

    image: nextcloud:latest

    container_name: nextcloud-app

    networks:

    - nextcloud_network

    depends_on:

    - letsencrypt

    - proxy

    - db

    volumes:

    - nextcloud:/var/www/html

    - ./app/config:/var/www/html/config

    - ./app/custom_apps:/var/www/html/custom_apps

    - ./app/data:/var/www/html/data

    - ./app/themes:/var/www/html/themes

    - /etc/localtime:/etc/localtime:ro

    environment:

    - VIRTUAL_HOST=fragoulisnaval.duckdns.org

    - LETSENCRYPT_HOST=fragoulisnaval.duckdns.org

    - LETSENCRYPT_EMAIL=fragoulis2010@gmail.com

    restart: unless-stopped


    volumes:

    nextcloud:

    db:


    networks:

    nextcloud_network:

  • FragoulisNaval: Unfortunately you tip didn't solve the problem.


    this is my config.php file so far: (the red lines have been added, **** placeholder)



    <?php

    $CONFIG = array (

    'memcache.local' => '\\OC\\Memcache\\APCu',

    'datadirectory' => '/data',

    'instanceid' => 'oca2qlx67y0v',

    'passwordsalt' => '****,

    'secret' => '****',

    'trusted_domains' =>

    array (

    0 => 'nextcloud.****.duckdns.org',

    ),

    'dbtype' => 'mysql',

    'version' => '19.0.0.12',

    'overwrite.cli.url' => 'https://nextcloud.****.duckdns.org',

    'dbname' => 'nextcloud',

    'dbhost' => 'mariadb',

    'dbport' => '',

    'dbtableprefix' => 'oc_',

    'dbuser' => 'oc_****',

    'dbpassword' => '*hidden*',

    'appstoreurl' => 'https://apps.nextcloud.com/api/v0',

    'appstoreenabled' => true,

    'installed' => true,

    );



    This is the an error from Nextcloud -> Settings -> Logging


    WarningappstoreFetcherCould not connect to appstore: cURL error 6: Could not resolve host: apps.nextcloud.com (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!