Web Control Panel login with correct credentials suddenly not working

  • Suddenly, I cannot login to the Web Control Panel. (At the same time ssh is no problem.)

    Credentials are correct (I am using Lastpass to auto fill the form fields). To be sure I have double checked and tried it manually as well.

    The Login seems to work (no errors) but after a few seconds the Login screen is shown again. It is in a loop.

    FYI: When I intentionally use a wrong password I get the usual red error message

    What I've tried to fix it:



    3 Change control panel administrator password

    4 Reset failed login attampts


    apt-get update && apt-get upgrade


    sudo reboot

    No success ;(

    What I suspect caused it:

    The last time I was logged into the web panel I was using the "Update Manager".

    I think the "upgrade" did not work. Unfortunately I can't recall the details.

    After that the problem happened.

    When I do this via ssh I get the following:

    apt-get update && apt-get upgrade
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • In the shell run df -h and see if the rootfs is full or not.

    Google is your friend and Bob's your uncle!

    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • I still can't login to my web control panel.

    Here is a short video-capture of 2 login attempts with correct PW and a final one in contrast with an incorrect PW:


    (I did refresh my browser Cache and tried it with different browsers)

    Samba shares work fine.


    Points 2 - 10 all work and confirm everything is valid

    Point 11 "Submit diagnostic report to administrator" is attached.

    apt-get update && apt-get upgrade

    worked with no errors

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • User Blocked:

    I regularly used first-aid to "Reset failed login attempt counter".


    I found something in


    2020/11/19 15:46:57 [error] 1800#1800: *63 FastCGI sent in stderr: "PHP message: PHP Warning:  session_start(): open(/var/lib/php/sessions/sess_d960ui2irim3oialm4hr26mje5, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 43" while reading response header from upstream, client:, server: openmediavault-webgui, request: "HEAD / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm-openmediavault-webgui.sock:", host: ""


    Code - - [19/Nov/2020:15:46:57 +0000] "HEAD / HTTP/1.1" 200 0 "-" "Monit/5.20.0"
  • Code
    root@rock64:~# systemctl stop php7.3-fpm
    Failed to stop php7.3-fpm.service: Unit php7.3-fpm.service not loaded.
    root@rock64:~# rm /var/lib/php/sessions/*
    rm: cannot remove '/var/lib/php/sessions/*': No such file or directory
    root@rock64:~# systemctl start php7.3-fpm
    Failed to start php7.3-fpm.service: Unit php7.3-fpm.service not found
  • Solved my issue with duffr's answer:

    chmod 777 /var/lib/php/sessions

    Thank's votdev for pointing me to the logs! That was quite helpful!


    On a cloned SD Card I also solved it with hugn's answer (which basically does the same to the "sessions" directory):

    sudo rm -rf /var/lib/php/sessions

    sudo mkdir -m 777 /var/lib/php/sessions

    ls /var/lib/php -l

    sudo nginx -s reload

  • wolf8auer

    Added the Label resolved
  • wolf8auer

    Added the Label OMV 4.x

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!