I need help getting back in to OMV Web Inteface

  • Hello,

    I've been having trouble getting logged back in to OMV 5 web interface.

    I don't ever post on forms, but I need help

    I can get in with putty and do omv-firstaid, where i get little luck doing the cleans and stuff

    often i get an error like this

    Error writing to output file - write (28: No space left on device) [IP: 52.36. 223.217 443]

    And here is the output of df -h

    Filesystem Size Used Avail Use% Mounted on

    udev 7.8G 0 7.8G 0% /dev

    tmpfs 1.6G 11M 1.6G 1% /run

    /dev/nvme0n1p2 101G 98G 0 100% /

    tmpfs 7.8G 0 7.8G 0% /dev/shm

    tmpfs 5.0M 0 5.0M 0% /run/lock

    tmpfs 7.8G 0 7.8G 0% /sys/fs/cgroup

    tmpfs 7.8G 0 7.8G 0% /tmp

    /dev/loop1 65M 65M 0 100% /snap/gtk-common-themes/1513

    /dev/loop0 64M 64M 0 100% /snap/handbrake-jz/142

    /dev/nvme0n1p1 511M 140K 511M 1% /boot/efi

    /dev/loop2 163M 163M 0 100% /snap/gnome-3-28-1804/145

    /dev/loop5 98M 98M 0 100% /snap/core/10583

    /dev/loop3 56M 56M 0 100% /snap/core18/1932

    /dev/loop4 65M 65M 0 100% /snap/gtk-common-themes/1514

    /dev/loop6 98M 98M 0 100% /snap/core/10577

    /dev/loop7 56M 56M 0 100% /snap/core18/1944

    /dev/sda1 458G 73M 458G 1% /srv/dev-disk-by-label-Backup

    /dev/sdb1 3.6T 14G 3.6T 1% /srv/dev-disk-by-label-4TB

    overlay 101G 98G 0 100% /var/lib/docker/overlay2/e50833dd76b8baa2a d5226d4d395600df6f63656ed28a01b89669d0325ae5331/merged

    overlay 101G 98G 0 100% /var/lib/docker/overlay2/0bcc75cd04120c008 5bb64d4ed75692ee0ecc5a963ac81a36230b32cf179b09b/merged

    overlay 101G 98G 0 100% /var/lib/docker/overlay2/537210b8e8f21b0fd e2d33a7e8f533f49b53d3554d8ab5d6f1f55b62f2daa55b/merged

    /dev/md127 2.7T 1.4T 1.4T 49% /srv/dev-disk-by-label-Test

    idk how everything got to 100%, but I assume this may be why i can't login, I don't know how to fix it. I've tried every command i can find on these threads with similar issue. I have tried cleans, rm, clearing logs and purger old docker data.

    I really can't lose this data, I'm not confident i can get the system back to way it was if I reinstall. If I can get back into the web interface i can get everything fixed I believe. My only idea is to copy the drive to a bigger one, any other help is very greatly needed.

    • Official Post

    Docker is filling up your root partition.

    Look in the guide forum and there is a thread addressing this problem and some possible fixes. If that does not help post back here.

    [How-To] Fix full OS filesystem - GUI login loop

    Beyond that however, you need to get your containers off your OS drive and onto a larger drive, but it would be better if you could get into the webUI first.


    I didn't know what was wrong and you gave me a place to start. I was able to login to portainer, and stop my containers, then I did a purge to docker and it cleared 2gb. I'm back into the web interface and i can get everything fixed now. You are a hero!

    I know i have to remake the portainer stuff but thats okay,

    • Official Post

    I have the root m.2 drive. 4 hard disks in a raid and one other 500gb I was using for random stuff and tests.

    OK.... Here's what I would do (assuming you don't want to set up all your containers again). Your docker folder is about 100gigs, so I'm assuming you have a big plex or emby database, or you've got video thumbnails enabled which can also make those containers huge.. but it appears your 500gig drive will be appropriate for this, as you only have about 43gigs in use on it.

    1. Create a folder on your 500gig drive called "Containers"

    2. SSH your server and become root.

    3. systemctl stop docker (This stops the docker service)

    4. mv /var/lib/docker /srv/dev-disk../Containers. (this moves your docker folder to the absolute path of your Containers folder)

    5. In the webUi for docker, change the path for your containers (which right now says /var/lib/docker).. to the absolute path for your containers folder. (/srv/dev-disk.../Containers)

    6. Click Save

    7. systemctl restart docker (this restarts docker).

    When you're done, your Containers should all be just as they were, but they are now running off your 500gig drive... so your OS drive should not fill up any longer.

    You may run into an issue where docker starts before your raid filesystem is mounted (assuming that is where your media is)... You'll know if you have this problem as when you restart, your containers will all be blank as if there is no data. SSH your server and type systmctl restart docker and when it's restarted, all your containers will be normal again.

    IF you run into that problem, macom suggested a handy edit in this thread that basically delays docker starting by 30sec, which is more than enough time for your raid file system to mount, thus working around the problem.

    Jellyfin portainer stack completely reset after 10-hour server shutdown: why?

    Hope that helps...

    • Official Post

    Just got up, thanks man!

    I do have another TB driver somewhere, should I copy my 500gb to it before I do this?

    You can... but the 500gig should give you plenty of space for whatever projects you're working on, and leave you room for your Containers. (Again, looking at the drive now, it's only got about 50gigs in use... so even if you double that, you still have about 400gigs for your Containers)...

    Only other thing I can suggest, is Docker will pretty much lock down that Contaiers folder, so don't put it under other directories, no need to share it over SMB/NFS, or try to use that particular folder for anything but your docker containers

  • Thanks for all your help, it was really frustrating last night. I used to know linux really well but I don't use it enough in my daily life to retain it. I finally have a decent internet connection with no data caps, so I'll be making sure I have a cloud backup so I don't have to worry again.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!