Still stuck on Kernel 4.9

  • I have a a OMV5 install that was installed with a 4.x kernel. But now it's still on Kernel 4.9.

    I thought this was normal until I did a fresh OMV install on a new machine and noticed that it's already running a 5.x Kernel.


    Why is my Kernel still stuck on 4.9? Is there a way to upgrade to the a newer version?


    I've tried running

    Code
    apt-cache search linux-image

    But it doesn't show me any 5.x images to install

  • So you'll have to enable the backports repository.

    Backports are enabled for the kernel by default on OMV. omv-extras provides a switch to turn it on and off as well.


    No, OMV 5 has the Kernel 5.9, Backport is 6.x

    Uh, no. There is no 6.x kernel. OMV 5.x uses the 5.9 kernel when backports are enabled. Otherwise, it will use the standard Debian 10 4.19 kernel.

    omv 5.6.8 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Backports are enabled for the kernel by default on OMV. omv-extras provides a switch to turn it on and off as well.


    Uh, no. There is no 6.x kernel. OMV 5.x uses the 5.9 kernel when backports are enabled. Otherwise, it will use the standard Debian 10 4.19 kernel.

    Hmmm, but I did not activate it. I did a fresh install and backports was enabled by default. It started with 5.4 and now it's 5.9.

    Don't have a 4.x installed on my system


  • Hmmm, but I did not activate it. I did a fresh install and backports was enabled by default. It started with 5.4 and now it's 5.9.

    Don't have a 4.x installed on my system

    OMV has been enabling backports for the kernel by default for a long time (since the 3.x days). So, this is to be expected.

    omv 5.6.8 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!