omv-extras repos moving to github

  • Because Bintray is dropping their repo hosting service (https://jfrog.com/blog/into-th…gocenter-and-chartcenter/) on 2021-05-01, I have moved the omv-extras repos to github. omv-extras 5.5 will change the repos to point to github. This package is in the testing repo now. People will have until bintray is shutdown to upgrade. I will move the 5.5 package of omv-extras to the regular OMV 5.x repo in a few days. I might release an OMV 4.x package with the updated repos but I am not releasing a 3.x package (the 3.x, 4.x, and 5.x repos are on github if someone wants to manually change the repo).



    OMV 5.x only!!! See post #9 below for OMV 4.x instructions


    If you missed grabbing omv-extras 5.x that updates to the github repos, just install the latest omv-extras:


    Install from command line as root wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

    Edited 2 times, last by ryecoaaron ().

  • The omv-extras 5.5.1 package has been pushed to the regular repo. So, this should start switching all systems to the github repos.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hyperlinks have been removed. I don't have a good alternative at the moment.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • "the 3.x, 4.x, and 5.x repos are on github if someone wants to manually change the repo."

    Ok thanks, can you please tell us the exact url for this manually update ? Whis this we can add the repo manually on omv-extra.

    Thanks in advance


    OMV 4x - Core i3-8100 - 3.6 GHz - RAM 32GB - HDD 6x 2TO (3x Raid1)

  • can you please tell us the exact url for this manually update ? Whis this we can add the repo manually on omv-extra.

    But your system will keep failing since this does not remove the bintray repos. And what is your motivation? It feels like people will just keep using 4.x even though it is EOL'd.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi thanks for your response.

    I have disable bintray repo to stop the failed update, that's ok

    Previously I make a backup of all plugin for the 4.x version from Bintray to my server.

    I don't want upgrade because 4x work fine with many modifications from me, and i like to use Virtualbox with integration on OMV.

    Perhaps in the futur i test the OMV 6.x and upgrade...

    OMV 4x - Core i3-8100 - 3.6 GHz - RAM 32GB - HDD 6x 2TO (3x Raid1)

  • I don't want upgrade because 4x work fine with many modifications from me, and i like to use Virtualbox with integration on OMV.

    I wrote a kvm plugin for OMV 5.x that is better than virtualbox (in my opinion). There is even an option to convert the virtualbox vdi disk images to kvm format to create the VM in the plugin. The kvm plugin is fully integrated with OMV as opposed to doing everything in phpvirtualbox (which is not really maintained anymore).


    Just because it works fine doesn't mean you should stop moving to newer, supported versions.


    I hate giving out these instructions because people will just stop upgrading...


    For OMV 4.x only

    cd /etc/apt/sources.list.d

    sudo mv omv-extras-org.list omv-extras-org.bak

    echo "deb https://openmediavault-plugin-developers.github.io/packages/debian arrakis main" | sudo tee omv-extras-org.list


    cd /etc/apt/trusted.gpg.d/

    sudo wget https://openmediavault-plugin-developers.github.io/packages/debian/omvextras2026.asc

    sudo apt-key add omvextras2026.asc


    sudo apt-get update


    Perhaps in the futur i test the OMV 6.x and upgrade...

    Unless you do a fresh install, that will still require moving to OMV 5.x first.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Very thanks for your help, I appreciate.

    I add this like that directly on interface (it seem work) :


    I understand your opinion about upgrade, and I really think you are right.


    People have to make upgrade for security, usage and support product.


    When the OMV 6.x release for prod (non for test) , it's a possibility for me to upgrade system with fresh install. Because my plan is to migrate all server to proxmox and using OMV only for stockage after.


    Bests Regards to you and all forum :-)

    OMV 4x - Core i3-8100 - 3.6 GHz - RAM 32GB - HDD 6x 2TO (3x Raid1)

  • Hello, I believe that I have missed updating during the period where bintray was still working. Whenever I try to look for regular updates or plugin updates using the check button I get an error along the lines of this. Note I am using omv on debian 10 Buster.


    Failed to fetch https://dl.bintray.com/openmed…ul/dists/buster/InRelease 403 Forbidden [IP: 34.209.176.102 443]
    E: The repository 'https://dl.bintray.com/openmediavault-plugin-developers/usul buster InRelease' is not signed.


    When I try the wget command you posted


    I still get the same error as above . My current version of OMV is 5.6.12-1 (Usul). Any guidance on how to get by this would be appreciated, thanks. I have looked on the forum and seen a similar problem were others disabled teamviewer and got things to work, but this did not work for me as "sudo omv-salt deploy run omvextras" yields the same error too.

    Any guidance is appreciated, thanks!

  • Post the output of:


    sudo rm /etc/apt/sources.list.d/omvextras.list

    sudo omv-salt deploy run omvextras

    sudo apt-get update

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Post the output of:


    sudo rm /etc/apt/sources.list.d/omvextras.list

    sudo omv-salt deploy run omvextras

    sudo apt-get update

    Following these instructions to remove mentioned file beforehand works.

    I can now check for updates and update as expected. Thank you!

    Here is the output from the commands for those interested.



  • Hi,

    I am running 5.5.23-1 on PI4.

    Started to get errors about :not signed repositories".


    Did

    Code
    sudo rm /etc/apt/sources.list.d/omvextras.list
    sudo omv-salt deploy run omvextras
    sudo apt-get update


    got


    Doesn't look right.


    What can I do to bring the system back to normal ?


    10x.

  • What can I do to bring the system back to normal ?

    Following the first post in this thread.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!


  • Please keep this repository up and running for OMV 4.1.36-1 (Arrakis). It is not about not willing to upgrade or use the latest version, it is simply that a running system like OMV 4.1.36-1 (Arrakis) should stay running using its best hardware today.


    Thank you ;):thumbup:

  • Please keep this repository up and running for OMV 4.1.36-1 (Arrakis)

    It is always going to be github. I have no plans to remove it.


    It is not about not willing to upgrade or use the latest version, it is simply that a running system like OMV 4.1.36-1 (Arrakis) should stay running using its best hardware today.

    This is not true. Anything running OMV 4.x can run OMV 5.x. And once Debian stretch updates stop, you should not be using an unsupported distro let alone and unsupport version of OMV.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • [...] And once Debian stretch updates stop, you should not be using an unsupported distro let alone and unsupported version of OMV.


    It did not mention anything about Debian Stretch. Sure, once the underlying OS is no longer supported, then most likely the original OMV version introduced for this Linux OS version is maybe no longer supported either. That's clear.

  • It did not mention anything about Debian Stretch

    You mentioned OMV 4.x which only runs on Debian Stretch and Debian Stretch is almost out of extended LTS support. Stretch was already EOL a year ago - https://wiki.debian.org/DebianReleases


    Sure, once the underlying OS is no longer supported, then most likely the original OMV version introduced for this Linux OS version is maybe no longer supported either.

    OMV versions will not be supported as long as Debian LTS support.

    omv 5.6.18 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.3 | kvm plugin 5.1.7
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi,

    I am trying to update my OMV 4.1.36 to 5.x according to Upgrade Scripts for non-interactive major release upgrades (2->3, 3->4, 4->5). I didn't make it successfully and searching for the error messages brought me to this post.


    I executed the command in #1, but still end up in error messages.



    Have I made an error?

    Do you have a clue what to do?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!