Errors in Portainer when deploying Transmission stack

  • System info:

    Raspberry Pi 4 (4GB)

    Boot Disk - SanDisk 32GB UHS Class1

    External - Toshiba 2TB USB 3.0 drive

    Portainer Ver - 2.6.0

    I was following Techno Dad Life's video "Easy Automated Home Media Server: VPN, Radarr, Sonarr, Lidarr, Librarian in 10 Minutes." And using the new docker-compose file from that video.

    When I get to deploying the stack, Transmission is never created as container. All other services are in the "created" state for their containers but do not start since there is no Transmission container running. In addition, when going back to the stack, it shows "limited" and reports that the stack was not created in portainer, despite being pasted into the portainer web interface. I'm very much to OMV/Portainer so any and all help is appreaciated!

    Here is the docker-compose file

    • Official Post

    This is going to be long as I'll try to be detailed, but a few things popped out to me. While I can't say these are your problems, and understanding I've never watched the video for more than a couple minutes...

    1. All of your "linuxserver" image names have been deprecated for some time... I think they *should* still pull the proper image, but you might as well start using the proper image names as a first trouble shooting step... Eventually I'm sure those names will stop working

    Example... Look at the docker-compose and look at the image name for lazylibrarian. All of the linuxserver images changed similarly:

    2. Your network modes don't look right. Maybe it works, but I've routed many containers through my "swag" container, and it just didn't look like that. First, since these are all being deployed (presumably) in the same stack, you shouldn't even need network mode... as they will all go through the first containers network (in this case, transmission-vpn).. even if you needed network mode however.. it still doesn't look right.

    Here's what I would do...

    1. Delete the entire stack and all associated images and containers.

    2. Click on Networks in Portainer, and delete all unused networks

    3. Create a new stack, this time, just run and setup transmission-vpn. Once transmission is set up and working... You can do one of two things to add another service to it:

    4. Add another service (ie, jackett) to the transmission stack. In this case, completely delete that network mode line. Redeploy the stack... see if jacket is working. Because it is getting deployed in the same stack as transmission, it should automatically get assigned to the same network. Make sure you're using the proper image name from the services linuxserver dockerhub page.

    hope that helps

    In a world without fences and walls, who needs Gates and Windows?

    Join us on Discord:

    Edited 2 times, last by KM0201: deleted a big part that didn't work how I thought it would ().

  • Thanks! That's all very helpful. Appreciate your time.

    Portainer gave me an error for the transmission image not being found. I went to the site and checked, and deleted the "latest-armhf" and then the stack deployed.

    The container reports back "unhealthy". I've attached the log file and included everything before the first restart where it all seems to be repeating after.

    _vpn_transmission-openvpn_1_logs (1).txt

  • I removed the :latest-armhf" and tried it again this afternoon and got it to install this time as well. Mine seems to be in a loop: Fatal Python error: pyinit_main: cant initialize time

    permissionError: operation not permitted

    options error: you must define tun/tap device)--dev)

    (I did uninstall portioner and docker and reinstall both yesterday when trying.)

  • That did the trick! Followed the guide for option 2 and now have a "healthy" status.

    One last (potentially stupid) question, since I will be trying to deploy the rest of the containers in the stack without a network mode, how can I verify that are running through the VPN?

  • One last (potentially stupid) question, since I will be trying to deploy the rest of the containers in the stack without a network mode, how can I verify that are running through the VPN?

    All depends on the application and if it was built with internal tools such as curl. So try this and see.

    Get a shell inside a container: docker exec -it <container-name> /bin/bash

    You can also get a shell inside a container via Portainer using the Quick Actions Exec Console in the Container list.

    Run this command at the shell prompt and examine the returned IP address: curl

    If the returned IP is your public IP, then you are not connecting thru the VPN. FIND OUT WHY.

    For any torrent application you should always be running a tracker IP ID torrent. This will show you what the trackers see as your IP address. Make sure it isn't your public IP address. Go here and follow directions:

    Google is your friend and Bob's your uncle!

    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • I was confused by where I should run the script. I was expecting I had to run them on OMV and not just the Raspberry pi. I ssh into the pi and ran them there as a test and it worked for me as well. Thank you all! Now to see if they actually run and work properly.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!