OMV update fail

  • Hi!

    Need some assistance.

    After repos moving to github my OMV fails to update.


     dpkg -l|grep -i openmedia  output (may be useful):

    sudo salt-call -l debug --local --retcode-passthrough state.apply omv.deploy.omvextras output - see attach:


    debug output.txt

    Possibly errors in debug output:


    Err:18 https://openmediavault.github.io/packages usul Release

    Could not handshake: Error in the pull function. [IP: 185.199.108.153 443]

    Ign:19 https://openmediavault-plugin-…github.io/packages/debian usul-extras InRelease

    Err:20 https://openmediavault.github.io/packages usul-proposed Release

    Could not handshake: Error in the pull function. [IP: 185.199.108.153 443]

    Err:21 https://openmediavault-plugin-…github.io/packages/debian usul Release

    Could not handshake: Error in the pull function. [IP: 185.199.108.153 443]

    Err:22 https://openmediavault-plugin-…github.io/packages/debian usul-testing Release

    Could not handshake: Error in the pull function. [IP: 185.199.108.153 443]

    Err:23 https://openmediavault-plugin-…github.io/packages/debian usul-extras Release

    Could not handshake: Error in the pull function. [IP: 185.199.108.153 443]


    How can I repair updates?

  • KM0201

    Approved the thread.
    • Official Post

    You probably have a proxy set or your network is causing the issue.

    omv 6.1.8-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • You probably have a proxy set or your network is causing the issue.

    This is my home LAN. No proxy configured on OMV and no proxy exist on network, only router with NAT. Also no ACL, no packet filtering etc.

  • This is my home LAN. No proxy configured on OMV and no proxy exist on network, only router with NAT. Also no ACL, no packet filtering etc.


    E-mail notification text:


    • Official Post

    E-mail notification text:

    I assure you that those repos have a Release files - https://github.com/OpenMediaVa…debian/dists/usul/Release and https://download.docker.com/li…bian/dists/buster/Release. Make sure the time on your system is correct. Disable the testing and extras repos as well. There is nothing in them. And I don't know where you are located but github is blocked in China. Probably some other places as well.

    omv 6.1.8-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I assure you that those repos have a Release files - https://github.com/OpenMediaVa…debian/dists/usul/Release and https://download.docker.com/li…bian/dists/buster/Release. Make sure the time on your system is correct. Disable the testing and extras repos as well. There is nothing in them. And I don't know where you are located but github is blocked in China. Probably some other places as well.

    I`m in Moscow, Russia. No problems accessing repos links via browser (other computer, but the same LAN, same router, same outgoing IP). I trying to disable all repos by OMV web-admin, but save config changes caused the same errors, and only way - to roll-back (revert) config (see screemshot).



    "Could not handshake: Error in the pull function" - may be somewhat with certificates or keys

    • Official Post

    If the system time is correct, I don't know what else could be causing this. I would make sure ntp (chrony) is running and maybe try the apt-clean button in omv-extras.

    omv 6.1.8-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • If the system time is correct, I don't know what else could be causing this. I would make sure ntp (chrony) is running and maybe try the apt-clean button in omv-extras.

    Time is correct. Apt-clean I tried at first - no result. I will try to restore system from backup (january 2021, but exist at least) and change repos again or make new installation and re-mount RAID5 volume.


    Thanks!

  • The story was continued...


    I shut down computer, change system SSD, plug-out all RADI5 drives and make fresh install fom actual iso-distributive.


    1. Installing OMV from DVD (+ administration settings - certificate, password etc) - it`s OK

    2. Installing OMV-Extras plug-in - it`s OK

    3. Checking and installing all available updates - Installation finished with errors and the same error appears with "Could not handshake" and "no Release file"


    I will try to investigate what update causing error (Fresh install again and install updates one-by-one) and inform in next post

  • as promised...


    1. Installing OMV from DVD (+ administration settings - certificate, password etc) - it`s OK

    2. No updates installing, no plugins installing, checking updates - it`s OK

    3. Turn on "Community-maintained updates." (off by defaut), save, check updates - "Could not handshake" and "no Release file"

    4. Turn off "Community-maintained updates.", reset, save, check updates - "Could not handshake" and "no Release file"

    5. Turn off "Community-maintained updates.", reset SEVERAL TIMES, check updates - it`s OK (may be timeout exists)

    6. Install OMV-Extras via terminal - "Could not handshake" and "no Release file", but OMV-Extras presents in Plugins

    7. Trying to add Extras plugin repo - unsuccesfull, "Could not handshake" and "no Release file", only way to revert config

    8. While OMV-Extras is added, OMV-FIRSTAID don`t works (!) - see output

    9. After uninstall OMV-Extras via web-admin - OMV-FIRSTAID is OK

    10. The probability of successfully updates (or plugins) checking after this config manipulations about 5-10%


    I remember - it was NEW fresh installation


    Something wrong with new repos!

  • You probably have a proxy set or your network is causing the issue.

    It seems problem found!


    Internet provider blocks network resources very selective. No problems accessing github repos via browser, but OMV-s connections don`t works or unstable.

    Using HTTP proxy (external) it was possible to establish a stable connection to repos and repair half-installed and failed packets.

  • yarvv

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!