Snapraid + mergers files copied to a single drive

  • Can somebody explain if this is expected, if I might have set something wrong or if this is just because OMV6/plugins are not yet release and still have a few teething problems and I need to wait until it's released?


    This is installed on Debian 11 using the OMV6 install script.


    I'm new to OMV and still trying to understand snapraid/mergerfs.

    I used this guide as reference https://www.networkshinobi.com…ergerfs-on-openmediavault


    I created four snapraid drives, three for data, one for parity.


    Created the mergerfs pool, while creating this, there was no available shared folders to select, the samba shares had not been created yet.



    Created the samba shares



    Checking the filesystem, with tree, I see the four shares


    I copied four movies to the samba Movies share.

    What I saw was, all the movies are copied to /dev/sda1.

    I expected that there should be a Movies folder on all disks and the movies should be copied to the drive with the most available space.

    What I actually saw was, all the movies are copied to /dev/sda1


    I check the mergerfs config and can see now that I'm able to select shared folders.



    If I try to add these. it returns en error, one part which complains about the file length.

    I'm not actually sure if I need to select these shared folders or if by not selecting them, that's why all the movies are copied to a single drive.


    Thanks for your time reading this.

  • Deofol

    Changed the title of the thread from “Snapraid + mergers fs files copied to a single drive” to “Snapraid + mergers files copied to a single drive”.
  • crashtest

    Approved the thread.
  • I ran into the same issue when trying to set up a mergerfs pool of eight disks. I got the "file name too long" error. After digging into the mergerfs documentation a bit, I decided to try "globbing". Try this as the path in the plugin:


    Code
    /srv/dev-disk-by-uuid-*


    It's working for me, and created the mount point under /srv/mergerfs/<name of pool>. Of course, this may not work for you if you have disks that you don't want to include in the pool since it uses a wildcard. I can only guess that there is an issue with the plugin with a character limitation or something since this worked fine in OMV5.

  • RE: omv-extras plugins - porting progress to OMV 6.x

    Here is the reason and how to use the wildcards to select the units that you want to include.


  • Using these examples work, specifically with [][][] so I could exclude certain drives.


    Also, using "most free space" in my mergerfs settings distributed files more evenly which is what I was also looking for.


    Thanks.

  • chente

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!