SOLVED: Cannot upgrade anymore on my OMV 5.x after the repository migration from BinTray to GitHub

  • Environment

    • Odroid Home Cloud 2 (ARM based SBC)
      • Open Media Vault 5.5.17-3 (Usul) — managed to upgrade to --> 5.6.21-2
      • Kernel Linux 4.14.204-odroidxu4 — managed to upgrade to --> 4.14.222

    How I had installed OMV in 6/2020

    • I had installed via the guide: Installing OMV on Single Board Computers
    • Flashed SD with image from https://www.armbian.com/odroid-hc1/ : Armbian_20.05.1_Odroidxu4_buster_legacy_4.14.180.img
    • Inserted SD and booted for initial Armbian setup
    • Connected via SSH with default credentials root/1234. Changed credentials.
    • Ran: apt-get update; apt-get upgrade; reboot
    • Connected via SSH
    • Installed OMV with single liner:
      wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash

    Problem now in 12/2021

    • Ran OMV for a few months in 2020.
      • Upgraded here and then.
      • Then didn't use it actively in 2021.
      • Though I let it ran idle to see how reliable it is: 100% uptime!
    • Now wanted to use it again, wanted to upgrade. Cannot upgrade anymore!
      • Web-UI > System > Update Management > Clicked "Check" --> Fails.

    Goal

    • I want to upgrade this to a more recent 5.x version or 6.x if that's recommended already
    • I do not want to loose:
      • the config/customizations on SD card
      • the data on the EXT4 HDD
    • The things I have extra to a base installation to my knowledge
      • Shairport Sync (AirPlay 1 audio player)
      • I did some manual bluetooth audio config, but later reset them AFAIR
      • I use a USB audio speaker (not sure anymore whether this needed a driver of config or worked out of the box)
    • Kind of succeeded in upgrading 5.x — read below — but still seems to not be in a good state yet.

    Fix attempts

    • Web-UI > System > Update Management > Clicked "Check". --> Failed.
    • The main problems as what I saw from the error messages/logs were:
      • repository changed its 'Suite' value from 'stable-updates' to 'oldstable-updates'
      • repository is no longer signed.
    • Web-UI > System > OMV-Extras >
      • General Settings: Was like this:
        • Testing Repo OFF
        • Extras Repo ON
        • Backports ON
      • Set "Extras repo" to OFF (Thought: "be as slim as possible for the upgrade attempt")
    • Web-UI > System > Update Management > Clicked "Check". --> Failed again.


    More successful fix attempt, but not there yet

    • Web-UI > System > OMV-Extras > Dropdown menu "Updates" has these entries:
      • update -> Failed again with the "no longer signed" warnings.
      • apt-get upgrade -> Seems to have worked. Upgrade ran for ca 30mins.
    Code
    The following packages have been kept back:
      armbian-config
    The following packages will be upgraded:
      [...]
    149 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. Need to get 108 MB of archives. After this operation, 1247 kB disk space will be freed.


    At the end of the log was:

    Code
    Errors were encountered while processing: openmediavault openmediavault-shairport

    And with the popup having the CLOSE button already active, at the very end of the log the follwing message kept repeating ca. every 1 sec:

    Code
    >>> *************** Error ***************
    Invalid RPC response. Please check the syslog for more information.
    <<< *************************************
    • Web-UI > System > Update Management > Now only listed:
      armbian-config, zip
    • Web-UI > System > Rotating error > Hovering over it said "System needs to be rebooted"
    • Rebooted.
    • Web-UI > System: Shows that it has indeed upgraded to:
      • Open Media Vault 5.6.21-2 (Usul)
      • Kernel Linux 4.14.222-odroidxu4


    Realized a dist-upgrade seems necessary

    https://askubuntu.com/question…-than-upgrade/99039#99039

    Quote

    Notice how an apt-get upgrade will say that the kernel packages have been held back. That's the cue for using apt-get dist-upgrade.

    • As armbian-config has been held back in my more successful fix attempt (see previous section) I interpreted this as a cue that I need to run dist-upgrade.
    • Web-UI > System > OMV-Extras > Dropdown menu "Updates" > dist-upgrade
    Code
    1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 354 kB of archives.
    After this operation, 507 kB of additional disk space will be used.
    • Okay! dist-upgrade seems to have "picked up the rest".
    • Web-UI > System > Update Management > Now lists nothing.

    Some problems seem to remain

    • Web-UI > System > OMV-Extras > Already disabled TestingRepo and ExtrasRepo.
    • Web-UI > System > Plugins > Clicking "Check" fails.
      • The main problem seems:
        The repository 'https://dl.bintray.com/openmediavault-plugin-developers/usul buster InRelease' is not signed.
        See: 6b-plugins-check-fails.txt


    Help appreciated!

  • chente

    Approved the thread.
  • The one liner "Install from GitHub" script fixed the issue

    1. Ran the "Install from GitHub" one line script as instructed here:
      https://github.com/OpenMediaVa…ges/blob/master/README.md
    2. Web-UI > System > Update Management: Listed 2 packages. Selected them. Clicked Install. Worked fine!
    3. Did not reboot. Continued using it.
    4. Web-UI > System > OMV-Extras > Reactivated "Extras Repo" which I had deactivated in an unnecessary fix attempt before. Clicked SAVE.
      • Ran for a while. Eventually gave error dialog with "communication failure".
        Also the details just said "communication failure". Nothing more.
      • Went elsewhere in the menu.
      • Went back to: Web-UI > System > OMV-Extras:
        "Extras Repo" still showed as active. Looks good as if the "communication error" was a false alarm.
      • To be absolutely sure, I rebooted. Then checked again. Still active. Nice! Was a false alarm indeed.
    5. Web-UI > Services > SSH: Permit root login: Disabled this as recommended by @chente. Save. Apply config change.
    6. Tested Airplay and Samba. Worked.


    👍 thanks chente this was indeed the issue at hand!

    • Updated the post title accordingly!
    • This post can be considered as SOLVED. 🙂

    Edited once, last by porg: By recommendation from @ryecoaaron I edited the link to the oneliner install script and mentioned that "Extras Repo" does not need to be de-activated and later re-activated and mention clearly that this was just my personal misfortune fix attempt. ().

  • porg

    Changed the title of the thread from “Cannot upgrade anymore on my OMV 5.x which was installed in 6/2020 and then over 2021 mostly idle w/o upgrades” to “SOLVED: Cannot upgrade anymore on my OMV 5.x after the repository migration from BinTray to GitHub”.
  • chente

    Added the Label resolved
  • the correct instruction is:

    The old instruction was not incorrect. You just weren't following what I wrote. And please remove the instructions and replace with a link to the official instructions - https://github.com/OpenMediaVa…ges/blob/master/README.md. That way, many places don't need to be updated. There is also no need to activate the extras repo (ever really).

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!