Rsync

  • Hi there,

    So I would want the following system.

    SystemFile Systemsync
    Truenas core 12.0u7zfslife
    OpenMediaVault 6ext4 Mergerfsevery week
    2 large Hard drives zfsevery 2 weeks




    SystemUsersGroups
    Truenas Core 12.0u7qnap,Eveline,guyf,ElizabethTruenas-Main,Eveline,Guy,Elizabeth
    OMV6guyfTruennas-Main


    Dataset/DirectoryOwnerAcces Groups RWAcces Users RWAcces Groups RAcces Users R
    pool/QDocumentenTruenas-MainTruenas-MainTruenas-MainTruenas-Mainevery member of group
    pool/QGameElizabethElizabethElizabethTruenas-mainevery member of group
    pool/QFotoguyfguyfguyfTruenas-Mainevery member of group
    pool/QFoto-not-publishedguyfguyfguyfguyf,Evelineguyf,Eveline
    pool/guyfguyfguyfguyfguyfguyf



    When I do my rsync I would like dat omv6 becomes a copy of Truenas.
    It needs to inherrit and change permissions, timestamps and of course delete extraneous files from destination dirs.


    I tried via the gui but got this...



    Then I went to putty and saw very strange behavior






    These are my settings for the rsync module.
    I changed user to guyf and this didn't help either.




    What am I doing wrong?

    I know this is rsync between different kinds of NAS but that's the situation at home.



    Kind regards.
    Guy

  • I am not using rsync modules, but -o requires rsync to be run as root when doing it manually by ssh.

    It may be that nobody is not allowed to se file permissions as well.


    Have a short test, running the module as root and then rethink the approch, if it works.

    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

  • Thanks for answering...

    I have run this command as guyf and root still no luck.
    I have now changed some settings in the gui.
    First only the user was coorectly filled in but the group had a 1002 number.
    Then I unvinked chroot and everything was fine.
    With mc I changed a file picture.jpg owner and the group and made the file 555 not writable by owner/group/other

    Still after rsync -av --progress /mnt/QData/Test-Truenas-Main root@192.168.1.7::guyf

    The owner/group of picture.jpg was the same as the original file and also the file had a 0775 permission setting just like the original.

    Thanks for helping



  • the user on the rsync command is the one to connect to the rsync module. The user you enter in the ui is the one who accepts the request and does the writing chowning, ...


    So now evryone who can connect to the module is able to write files as root. This is dangerous. You are allowing this to everyone.


    This is what i meant by rethink.

    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

  • If it is that large, check that you do not have the -v flag set and pipe the messages to a file.

    The log file is on /var/log/rsync.log and my fill up your os drive completely.


    check the size with ls -lh /var/log/rsync.log

    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!