Raspberry PI OMV 5 -> OMV 6 migration: NTFS mount

  • Hello to the community,

    Tried to google the answer for this one, but didn't manage do to that:

    I've migrated from OMV 5 on my RPI4 and everything went pretty smooth except disc mounting. I have 1TB NTFS drive, which was mounted to OMV 5 with ntfs-3g, all the shares with different protocols and docker were installed with it. Yes, I know that ntfs is not a good solution for OMV, but I can do nothing with it atm.

    After the migration my share records are the same as on OMV 5, but the sharing itself doesn't work because the shares have no file system provided.

    My disc is connected and mounted (I can see it in 'Disks' and 'File Systems' section), but as soon as I start new Shared Folder creation (or modifying the old one) - I face with an issue where I Can't select a file system because it doesn't come out from the drop down.

    I tried unmount and mount the disk with terminal - it doesn't help.

    Any advices aside of wiping ntfs system would be appreciated.

  • Thanks for your reply, I tried this approach and it didn't work for me (Google Chrome).

    I tried to open OMV6 UI from different browsers (which I never used for this purpose before) - the same result on FF and Safari.

    Going to look at full HDD unmount.

  • Full HDD unmount helps here. I started with all old shares left from OMV 5, all Shared Folders - deleted all of them, unmounted the disk (unmount button becomes active after all shares are removed) and rebooted Raspberry, all from UI. Then I opened UI again and mount the disk back, and then it worked as expected (I can select ntfs drive as path for sharing folders again).

    Moved to resolved.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!