Raid1 is missing

  • That's disappointing...

    root@openmediavault:~# e2fsck -b 32768 /dev/sda                                                                                                                                                                    
    e2fsck 1.44.5 (15-Dec-2018)                                                                                                                                                                                        
    /dev/sda is in use.                                                                                                                                                                                                
    e2fsck: Cannot continue, aborting.                                                                                                                                                                                 

    and ....

    root@openmediavault:~# sudo umount --force /dev/sda                                                                                                                                                                
    umount: /dev/sda: not mounted                                                                                                                                                                                      

    Any clue, how this can be?

    • Official Post

    Ok, you've run fsck on the array /dev/md0 and it's come back with a possible solution from your post 19, run the solution on /dev/md0 not on individual drives

    I also think the problem is me understanding what you are asking as this line -> Should I do the e2fsck -b 32768 with the drives you're asking should this be run on the drives, I should have answered no, it needs to be run on the array (/dev/md0)

  • That's a kind of a hen/egg problem.

    By searching around, I also noticed is that the folder by-label doesn't exist.

    root@openmediavault:~# dir /dev/disk                                                                                                                                                                               
    by-id  by-partuuid  by-path  by-uuid                                                                                                                                                                               
  • Yes, I've tried the other one as well. The result is the same.

    The mountpoint is okay then.

    root@openmediavault:~# dir /srv                                                                                                                                                                                    
    dev-disk-by-label-Raid1  ftp                                                                                                                                                                                                                                                                                                                                                          

    But that's also useless..

    • Official Post

    Yes, I've tried the other one as well. The result is the same

    Then you're confirming what is already known

    The mountpoint is okay then

    No, didn't say, I just pointed out to you that is where the mount point is after you did dir /dev/disk for whatever reason

    Why run e2fsck on the mount point, that can only be run on a device.

    There is nothing else to do, other than to try testdisk on each drive and see if there is any data that is recoverable, but I doubt it!!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!