Very slow transfer speed accessing my nas remotely.

  • I created a Nas with a raspberry pi and OMV and plugged in a 18 tb hard drive and connected my pi to my home router via Ethernet cable. My home internet is fast, up and down 30+ Mb?


    I setup OMV with samba and I installed wireguard and configured it with OMV and added my devices, however when I try to upload files (mostly pictures and videos of travel) it is very slow (tops out around 400Kb) taking hours to send videos.


    I am using my android phone to transfer the files using a program called X-plore. I have no problem connecting with my Nas it just has very slow transfer speeds.


    How do I trouble shoot this and would actions should I take to find a way to increase my speeds? What is causing the bottleneck?

  • No one have any clues? The whole reason I created my NAS with OMV is to be able to send pictures and 4k videos to my archive drive while I travel. I literally spent 2.5 nights (letting my phone transfer while I was sleeping) at 2 separate hotels with tested fast up and down internet connections. I have no clue how to trouble shoot the issue. Samba config? Wireguard? My android app? I connect just fine to my NAS remotely, but maxing out at 400kb in this day and age hearkens back to the day of dial-up.


    Anyone able to offer advice or solutions?

  • Skyhi

    Changed the title of the thread from “Very slow transfer speed with wireguard” to “Very slow transfer speed accessing my nas remotely.”.
  • Hi Skyhi, I am having the exact same issue and have yet to resolve it.

    - Raspberry pi 4 connected to LAN

    - Fiber internet 300 mbps

    - OMV with SMB

    - Wireguard VPN


    Transfers work great on the LAN but transfers on the VPN outside of the network are tremendously slow. A 100 MB video takes minutes to load.

    I'm not an expert in this field but I'm wondering if either

    1. The PI isn't powerful enough to encrypt/decrypt the files over VPN
    2. We're throttled by the router when connecting to it using the public IP

    I tried changing MTU values but haven't had much success or if that is even worth looking into.

  • It's frustrating at the lack of help, on the issue here... It seems pretty important, as a big reason to create the NAS was to be able to transfer large files while I travel, and I believe this is the relevant place being I created my NAS with open media vault software. I can't believe we are the only ones with the issue out here, but I am not technical enough to trouble shoot it completely myself. There is no way it should max out at 400kb, and it shouldn't take days (as in letting the files transfer overnight while I sleep, then continuing the next night again, repeat.) especially when my home internet is 40MB/s and the away internet was 100MB/s (with corresponding fast upload speeds). My pi is pi4 with 4gb of ram. It is sitting idle 99% of the time, as I set it up to mainly do this one task, so I can't see it being overloaded. It is also plugged in to the router via Ethernet cable. I simply do not know how to fix it, I don't know where to start, or how to troubleshoot the issue. But it is completely inadequate speed wise as it is. If you find a solution, please pass it along.

  • SMB seems to be well known for being very very slow over a VPN connection.

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Maybe look at other options, such as webdav, maybe?

    NFS?

    Asrock H370M-ITX/ac | i5-8400T | 16Gb RAM | Node304 case | 4-3Tb HDDs | 256Gb nvme | 128 Gb SATA SSD

    • New
    • Official Post

    I've never had any problems with samba over Wireguard with Openmediavault, for what it's worth. I do this a lot with large file transfers.

  • I've never had any problems with samba over Wireguard with Openmediavault, for what it's worth. I do this a lot with large file transfers.

    Would you mind sharing your setup? Maybe there is something we configured incorrectly?


    I used "curl -L https://install.pivpn.io | bash" to install wireguard using a static IP and cloudflare as the DNS provider.

    I used my public IP address to connect to the server.

    I then added a firewall rule to port forward to the raspberry pi.


    I have read some about making modifications to the MTU values but haven't had much luck with that.

    • New
    • Official Post

    My configuration is the one described in the wiki using the plugin without variations.

    On the other hand, I wouldn't be surprised if Cloudflare was the problem, all your traffic runs through their servers if I'm not mistaken. I would try some configuration that does not depend on a third party if possible.

    The MTU setting can play a role if you set inappropriate values. The total length can cause packages to be split into two parts and you may have twice as many packages in your shipment. But the default value set by the plugin should be adequate in most cases.

  • Just to update.

    I also tried a fresh install and using tailscale with the same result.

    I also tried using a USB to ethernet adapter just to rule that out, same result.


    Seems to be related to my network.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!