Rsync successful, but no file transfer

  • Hi all. First time build in OMV.


    Been trying to troubleshoot this all day. Trying to do a basic rsync through the UI. Sync one shared folder with another.

    When I run tests, I get messages that the sync was completed successfully, but no files make it to the destination folder.

    I tried seemingly every attribute in rsync.


    The only thing I can think of is that the source is NTFS and the destination is EXT4 - this might be causing problems?? would rather not reformat my drive to validate.

    Thoughts on how I could troubleshoot?


    sending incremental file list
    deleting test1.jpg
    ./
    test.jpg

    sent 974,898 bytes received 766 bytes 650,442.67 bytes/sec
    total size is 136,980,446,778 speedup is 140,397.15
    The synchronisation has completed successfully.

    END OF LINE

  • crashtest

    Approved the thread.
    • New
    • Official Post

    According to that output the synchronization is running and the result is the deletion of the test1.jpg file

    Maybe you should check which is the destination and which is the source in the rsync job?

    There is a button that you should use until you are sure that the configuration is correct, the Trial run button. It will simulate the work but will not modify anything in the files. When you are sure you have the settings you need you can uncheck that button.

  • Thank you. Yes - I've used the trial run. It's odd because the source, destination and all the data in the log messages appears correct (source, destination, test file removed, test file added) but no action is taken at the destination. The file never appears when the trial run is not checked.


    6/2/2024, 6:15:55 PM total size is 136,980,446,778 speedup is 140,397.15

    6/2/2024, 6:15:55 PM sent 974,898 bytes received 766 bytes 650,442.67 bytes/sec

    6/2/2024, 6:15:54 PM >f+++++++++ test.jpg

    6/2/2024, 6:15:54 PM .d..t...... ./

    6/2/2024, 6:15:54 PM *deleting test1.jpg

    6/2/2024, 6:15:54 PM building file list

  • Ahh. I figured it out. The issue was how I setup the shared folder. Was trying to set it up connecting it to an existing folder, instead it appears I created a new folder that was not visible in the targeted directory structure. After updating the relative path, it all works correctly.

    Apologies if I wasted anyone's time.

  • chente

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!