Odroid HC2 - Armbian to 24.5.1 with Linux kernel 6.6.31-current-odroid-xu4 issues

  • Hi,


    lately I updated my Odroid HC2 to OMV 7.7.1. Armbian to 24.5.1 with Linux kernel 6.6.31-current-odroid-xu4.


    After the update I re-applied the power optimization for HC1/HC2 from armbian-config and rebooted.


    It's working fine apart from a particular slowness I noted when connecting in ssh. I authenticate with keys and noted that the connection gets longer to successfully open.


    Could you help me find what could be causing such behavior? Maybe the HC1 power configuration from armbian-config is too much conservative in the latest update?


    Thank you!

  • My Odroid HC2 has also slowed. Besides the SSH slowness, my RSYNC data backups are taking much longer. I haven't researched the problem yet.

  • I ran the armbian-config utility and noticed that the CPU speed setting was 'false'. I left it the same and exited. Upon closing the utility, there was a message that the SOC runs between 200 and 2000 MHz. I don't believe that I changed anything except clicking 'done'.

    My HC2 now runs perfectly normal once again. Before and after reboot. Fast SSH and RSYNC.

  • When i run armbian-config it says it runs with ondemand governor between 200 and 200 MHz. So it's the same for min and max. No idea why.


    Tried to set CPU frequency to false and apply DBT as HC1/2 again but I still see I'm between 200 and 200...


    dano15 which kernel version are you running?


    There are updates I'm not able to install, I received notification saying to run dpkg --configure -a. It starts with containerd.io and after some seconds it just reboots, probably due to high memory/cpu usage. Trying to update from OMV webui shows errors also.


    What could I do? At this point if an update fixes something for this I can't even install it because of the dpkg command I should run and that instead ends rebooting my system.


    When I run dpkg --configure -a it hangs here and reboots every time.


    Code
    steakhutzeee@dk:~$ sudo dpkg --configure -a
    [sudo] password for steakhutzeee:
    Setting up containerd.io (1.6.33-1) ...

    EDIT: Enabled the maximum frequency available manually from armbian-config -> CPU (deprecated)


    How can I set a correct CPU freq manually now in order to not cause damage in the meantime that this is fixed?

  • steakhutzeee

    Changed the title of the thread from “Odroid HC2 slow ssh connection” to “Odroid HC2 - Armbian to 24.5.1 with Linux kernel 6.6.31-current-odroid-xu4 issues”.
  • I'm running OMV 7.1.1-1 Armbian 24.5.1 with Linux 6.6.31-current-odroidxu4.

    I haven't had any problems applying new updates.

    I assume your problem with the package updates is the root of your CPU frequency problems.

    I don't have any experience with setting the CPU frequencies.


    I just applied the new update - OMV 7.2.1-1 . Everything is still fine.

    • New
    • Official Post

    How can I set a correct CPU freq manually now in order to not cause damage in the meantime that this is fixed?

    For the HC2:

    sudo omv-env set "OMV_CPUFREQUTILS_MINSPEED" "600000"

    sudo omv-env set "OMV_CPUFREQUTILS_MAXSPEED" "1900000"

    sudo omv-env set "OMV_CPUFREQUTILS_GOVERNOR" "performance"

    sudo omv-salt stage run prepare

    sudo omv-salt deploy run cpufrequtils

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Following armbian forum https://forum.armbian.com/topi…-6631-current-odroid-xu4/ I applied some changes to the /etc/default/cpufrequtils directly and rebooted. Now armbian-config says I'm at 200-2000 MHz.

    You think it's enough or I should I apply the values the OMV side as you suggested?


    Changes I applied manually:


    $ cat /etc/default/cpufrequtils

    ENABLE=false

    GOVERNOR=ondemand

    MAX_SPEED=2000000

    MIN_SPEED=200000


    Also you suggest the performance governor?

    • New
    • Official Post

    You think it's enough or I should I apply the values the OMV side as you suggested?

    I am very familiar with how armbian sets cpufrequitls which is why I said to do what I did. If you just set the values in /etc/default/cpufrequtils, it will be overwritten by OMV. So, you must set the defaults in /etc/default/openmediavault to override the values which is what my commands are doing for you. I just couldn't remember the exact values and didn't want to get my hc2 out.

    Also you suggest the performance governor?

    Depends on whether you want energy savings or performance. I don't have a strong preference. I haven't used my xu4 or hc2 boards in a long time.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Thank you.

    Have a couple of question:


    1- From armbian side I see that cpufrequtils is a deprecated package and that Armbian just reads /etc/default/cpufrequtils for the values there. That's why it was set to ENABLE=false.


    Quote

    As of the 24.05 release Armbian no longer uses the package cpufrequtils. It now uses that configuration file directly, and replaces the basic functionality that the package cpufrequtils formerly provided.

    So the Armbian hardware optimization service reads this file and applies the values to the system, and armbian-config is responsible to modify it.


    Now I used the commands you suggested and they set ENABLE to true again.


    So I'm curious to understand how this relates to what Armbian says about it.

    If in the future I reapply again a DBT configuration from armbian-config I suppose it will overwrite these values, and setting CPU to false in armbian-config will also set ENABLED=false in this conf file again. These value should then be overwritten by OMV if I understood correctly, so what's the point of the armbian-config changes?


    Also CPU options in armbian-config are actually set as deprecated in the menu.


    So how all this is related to Armbian way of managing cpu freqs? The package is still used by OMV while not used by Armbian?


    I found this https://forum.armbian.com/topi…nd-governor-doesnt-apply/ interesting:


    Quote

    Yeah that. Well, cpufrequtils and big.little clusters don't mix well as you probably noticed.

    cpufrequtils itself has been deprecated for well over a decade.

    Since cpufrequtils was being inflicted on otherwise perfectly working, DT-controlled boards, we've disabled it by default.

    Boards that are proven to require it can re-enable it directly on the board as you've already found out or in the Armbian board file via 'CPUFREQUTILS_ENABLE=true'

    All that said, the real, kernel-supported alternative, cpupower, requires kernel-tools build which is currently not provided by Armbian (nor is usbipd, perf, nor any other kernel userspace tool, due to the complexities of release-dependent building of parts of kernel which is normally userspace-agnostic).


    2- Also here https://docs.openmediavault.or…eral/powermanagement.html looks like default values for min and max freqs is 0. What's that for? I had set to top before applying my custom values.


    Thank you again!

    • New
    • Official Post

    So I'm curious to understand how this relates to what Armbian says about it.

    If in the future I reapply again a DBT configuration from armbian-config I suppose it will overwrite these values, and setting CPU to false in armbian-config will also set ENABLED=false in this conf file again. These value should then be overwritten by OMV if I understood correctly, so what's the point of the armbian-config changes?


    Also CPU options in armbian-config are actually set as deprecated in the menu.


    So how all this is related to Armbian way of managing cpu freqs? The package is still used by OMV while not used by Armbian?

    When you install OMV, you shouldn't be using armbian-config for setting cpufreqs anymore. It does not matter that Armbian is not using cpufreqs because OMV is. I pretty much never use armbian-config.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!