HPE Proliant Servers

    • Official Post

    The disk is visible in

    Storage/ Disks/

    Iccan create it in

    Strage/File systems/

    but than its gone ....

    We seem to have got crossed missed posts, dis you wipe the drive before creating a file system?

    but i dont which bay in the server. is it important somehow?

    It's not important, but I keep a spreadsheet with each drives reference, bay that it's in, make, model and serial number that way I know if a drive needs replacing I know where it is.

  • We seem to have got crossed missed posts, dis you wipe the drive before creating a file system?

    No! and thats it !
    i wiped it in Disks and that formated it in Filesystem with Btrfs.
    no i want to maky a daily (or 2 or more often) backup OR Rsync.

    i think i will use rsync

    boring OMV.
    it runs and and runs and runs and runs and ru ...

  • Hello every one,

    I installed OMV 3 back in 2016 on a Gen 8 proliant (bios J6) following the tips.

    Here is what I did :

    1. boot with debian live key in usb port and a fresh ssd in the front bay
    2. installed debian (them omv) on that ssd
    3. rebooted on the ssd
    4. from debian, I flashed a usb key with supergrub2.
    5. moved the ssd to the optic sata port
    6. rebooted and everything worked fine.
    7. installed 4 WD 3to in the front bay (software raid 5 etc.)

    Tl;dr : I used to boot on an SSD (optical drive), launched via USB (supergrub).

    Every thing worked flawlessly.

    Since yesterday I can't boot on any hard drive which ever the port I place them.

    I tried both disks on other machines (usb boot key and ssd) and I can mount them and see the partitions.

    I tried to boot from super grub but I can't see any hard drive in super grub. When I list the partition, the hard drive is there, but I can't find any boot partition (altrough I booted from it the day before). I tried supergrub and another ssd (with debian 9 already installed) but it doesn't work either.

    I can boot on a live usb image and reach the desktop where I can see my SSD partitions... But I still can't boot them.

    Every time I try to boot on a hard drive, it's skipped and it tries to boot from network (NIC) which fails after the DHCP server gives it an IP.

    What is wrong with my gen8 ? What can I do to solve this problem ?

    Any help would be greatly appreciated.


  • Any error message ?

    Maybe something like "error: 'grub_calloc' symbol not found."



    There's no error message...

    But I tried something else :

    I set up sata AHCI in bios and tried again.

    I can boot on the first SATA port containing a hard drive, I can't boot from USB with grub :(

    I'll try to create another key from recovery mode since it's now possible.

    Thanks for your answer

  • What boot order do you have in your setup ?

    Do you know about the power of the iLO ?



    usb, cd, hd and the rest.

    I can do ILO (I forgotted it existed since the nas hasn't failed in 4 years).


    I created another bootable usb drive and it's not working.

    As long as there's only one drive (ssd with system) in the SATA ports, I can boot from it.

    As soon as there's another drive in the front bay it won't boot.

    It doesn't seem to boot from the usb drive anymore...

    Is there another way to boot from the 5th drive ?

  • In AHCI mode, it will always try to boot from the first HD.

    I have 4 data drives, one SSD connected to the internal SATA Port and the bootloader on the internal SD-Card.

    Was a bit tricky to get it running ...

    You can use the "boot once" menu to boot from your installation/rescue media.

    Maybe remove the 4 data drives, leaving the SSD and your USB stick connected and boot once

    from (virtual) "debian-10.5.0-amd64-netinst.iso" and choose "repair grub"

  • Thanks for your answer.
    I'll try that before patching the bios et setting up raid 1 for my ssd as explained here (french).

  • Hello there,

    I've made some progress and here is what I found :

    My Proliant Gen 8 won't boot anymore from SOME usb keys :

    • linux distro (debian 10, 9, whatever) : fine, will boot and install a linux system on any hard drive
    • grub USB key (the one you download online and flash from another computer) : fine also (but won't see the installed linux as it used to do)
    • grub bootloader (the one you create after installing linux) : NO GOOD. WILL NEVER BOOT. It worked flawlessly for 4 years, but I can't make it work anymore

    It will still boot from hard drive (only from the first one, as you know).

    After many attempts I swaped the SSD in the first port of the front bay and the first Raid drive to the optical port.

    It works...

    As you can see on the picture, the SSD is in port 1 and the drive that used to be there is on top.

    It's the only workaround I've found atm.

    During the boot, mdadm seemed unhappy but managed to create the raid and OMV tells me it's "clean".


    I guess I could create a raid 1 with only the SSD in it as decribed here (french link, sorry) which would allow me to boot directly from the SSD...

    So, here's my question :

    1. Does creating a raid 0 array for the SSD erases his data ? I guess so. (Dynamic Smart Array B120i raid)


    I Had another question for which I've found on stackoverflow it's possible :

    2. Is it possible to recover the MDADM raid 5 from another install ? There's still important data I would like to keep...


  • So...

    To make it work I had to choose between something hazardous and something even more hazardous :

    1. have the SSD in SATA 1 and a storage disk in SATA5

    2. Activate RAID 1 on SATA 5 and reinstall everything.

    I choose the fastest way and it seems to work (MDADM is still unhappy but it finally says the raid5 is "clean"). Here's what I did :

    I unscrewed the backpanel with sata connectors, I removed the sata 1 and cut some tape to free enough lenght of cable. I pluged the SSD on sata 1.

    I plugged the HD storage in the first port, with the cables that used to connect the SSD.

    Now the Microserver boots directly on SSD, no usb/SD/raid1 required.

    It is an ugly hack which I'm not proud of, but it works.

    I guess I'll replace the whole server as soon as I'll have enough money...


  • Hi I could you help, I bought an HP ML30 Gen9 second hand, its shows a 270 - iLo cant communicate error at boot, I have tried to install the latest service pack but the firmware bios wont update, I have even tried installing the bios from the system menu and this fails also the intelligent provisioning fails to install, I have been trying to get an answer on the HP forums for 2 weeks with no success. Any help would be appreciated thanks

    • Official Post

    Hi there.

    Normally, when RBSU cannot communicate with iLO is due to a misconfiguration or a corrupt iLO firmware. There are a few things you can try out:

    1. Enter RBSU (F9) during post, and reset RBSU to manufacturing defaults.
    2. If that doesn't work, and you already have OMV installed, install hponcfg and attempt a factory reset from the CLI with hponcfg /r
    3. If that also fails, completely turn off your server and remove the power. Then remove the CMOS battery and leave it out for an hour.
    4. Re-install the battery and power up your server again.

    Removing the CMOS battery will erase all the RBSU and iLO4 settings from the server. If this doesn't resolve the issue, is probable that iLO has a corrupted firmware EEPROM. This may require the motherboard to be replaced.

  • Hey Spy Alelo ,

    thank you for helping all of us out here.

    My question is kinda tech and general hardware related.

    I am using a HP ProLiant ML10 v2 for over 6(?) years now (upgraded with a E3-1220). I have 7 HDDs and 2 SSDs (glued to the bottom of the case) and no chance to put in more drives. Performance is fine for OMV, Nextcloud and some containers.

    Recently I thought about new network hardware and a 19" rack. Therefore I want to put my OMV-Server into the Rack too. Do you have any recommendations what to look for at eBay and so on? I have like no plan about rack servers, but I love iLO and would like to move on with HP/E. I am open for both viable options: 1. Move the ML10 parts into a rack case and 2. Buy a used server and have a second one.

    I am kinda tending towards option 2 since I never reinstalled OMV after like Version 3 (just deleted php5 & 7.0 today :D ). I could buy a complete new SSD and 2 more drives, copy all data from the old server, reuse most of the drives from there and move on with the new server.

    Thank you very much in advance!



    • Official Post

    You have a couple of options. I would have to either convert towers to rack servers or use a shelf for towers in our racks. These shelves are not exactly cheap, but you may be able to find it used on eBay. Since the ML10 v2 is fairly lightweight, you can use 417705-B2 as long as your rack is deep enough for it.

    Or use a generic rack shelf and pad it with some packing foam, secure the tower to the shelve with a Velcro strap around it so that it won't move around (that's what I had to do sometimes).

    Buying a used server is not a bad idea at all, it all depends on what you want to do. If it is just for storage, I'd recommend the MicroServer Gen10+ which is relatively inexpensive even when new. It has x4 LFF bays, x4 Ethernet ports, and a PCIe slot. You can easily get that, add four very large SATA hard drives and get an inexpensive PCIe to M.2 NVMe adapter with a cheap M.2 NVMe for the OMV OS. Although it does have the iLO5 chip, you do have to purchase the iLO5 network adapter which if you shop around, you can get for less than $50.

    I got that server for myself and I have x4 10TB drives, for a total of 30TB of storage. Honestly, the small size, lower power consumption, low noise and low heat that comes out of it really made it totally worth it for me. Plus, it looks pretty!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!