7-10 Megs/Sec on USB 3.0?

  • I have a quad core NAS running the latest OMV image with 8 SATA 3.0 disks. The sizes vary, but they're all 7200RPM and part of a Mergerfs pool.


    When I attach a USB 3.0 drive to the NAS directly and use Midnight Commander to move files onto my storage pool, the transfer rate is terrible! I'm getting 5 megs on the low side and 10 on the high side. If I plug the same drive in on my laptop (which only supports USB 2.0) I can more than triple those speeds. Any idea what the problem is?


    I wish I could test speed moving files over the network, but my switch is 10/100 so that isn't going to be a good troubleshooting option at the moment.

  • Update: If I use a crossover cable to get a gigabit LAN between two devices, I'm able to get 20MBPS via a Samba network share.


    I still think that's a bit slow, but I'm willing to deal with 20MBPS. However, USB 3.0 should be blazing fast, not 5MBPS. If anyone knows what's going on here (Linux driver?) I'd like to hear your thoughts.

  • I have to ask stupid questions:
    Do you have usb 3.0 hub in your motherboard?
    If you have 3.0 Did you plug the drive into the usb 3.0 port (the blue color one)?



    Now, not stupid questions:
    Have you tested a transfer in between system.drive and usb drive using cli with rsync?

  • There are no stupid questions, I'm sure that people have made those mistakes in the past.


    I do have 3.0 on the board and I've tried both 3.0 and 2.0 ports. The speed results are the same, but I don't understand why. I have not tried using rsync to do a transfer to the system drive because the OS drive is pretty small. Putting anything on it would be a stretch and probably wouldn't last long enough for me to get a reading on the write throughput :-/

  • I have never done a dd write test before, so I took a look around and found this article. He says you should dd to a blank disk or blank RAID array, otherwise you might end up losing data. All of my disks are storing valuable data, so I don't want to overwrite anything. Can you advise as to how I might do a dd speed test to my RAID without data loss?


    Also found this article with a lot of cool/helpful info about dd commands.


    lsusb reports both hubs, a 2.0 and a 3.0 root hub, as well as a 2.0 4-port hub. I don't know where the four port hub is, though. I have 2x2.0 on the rear of the motherboard and 2x2.0 on the front of the case, attached to a header on the board. There is no 4 port 2.0 hub anywhere on the device. There is a 4x3.0 hub on the motherboard, though, so I'm guessing that Linux is reading those 3.0 ports as 2.0. Does that sound correct?

  • I have found that reading from NTFS on OMV is reasonably fast. Not sure what your problem is.


    If moving stuff over the network is faster, just do it that way.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!