How to install Seafile with MySQL and SSL

  • I think there are two versions of the mysql plugin floating around, one from stable one from testing archive.
    One has the drop down, one needs an entry in extra options.
    Don't know which one is the one with the drop down, my guess is it is in testing.

  • FYI: Version 5.1.4 is released:

    Seafile Server 5.1.4 for Raspberry Pi….1.4_stable_pi.tar.gz.tar

    -> Be aware that it's packaged twice. 1) extract with "tar -xf ...." 2) extract with "tar -xzf ...."

    Update procedure:
    - Stop Seafile
    - Be sure to use the seafile-dedicated user from now on:
    - Extract downloaded file
    - Check that all permissions are correct, according to your user used for seafile
    - Select appropriate update script in the extracted directory (e.g. seafile-server-5.1.4/upgrade/
    - Execute the script.
    - Start Seafile

    - Delete old seafile version, or keep it as a fallback version

    OMV 3.x | Banana PI (M1) | | | Seafile Server
    OMV 4.x | ShuttlePC SH55J2

    Edited 3 times, last by sieben ().

  • Tried to upgrade seafile today, but encountered an error:

  • Tried to upgrade seafile today, but encountered an error:

    Are you sure you need to run as sudo?
    To my undserstanding this should be run as the seafile user.

  • The avatar folder is part of seafile ever since.
    If you do not have it, the application would show a strange behaviour.
    One thing which might cause these kind of errors is if you run the seafile scripts with different users (which changes file permissions on the go)

    So to all:

    Do only run seafile scripts as the seafile user.
    Do not use sudo unless you did installed as root.
    If things go wrong, check file permissions and ownership first.

  • Thanks Zoki, I totally agree!!

    AND: Stop the seafile server before upgrading!

  • I see script errors sometimes where a folder needs to be created. But if one of you were able to upgrade fine and the other not I am not sure what the issue is for @tinh_x7. He seems to be having a lot of odd problems on his system.

    No, I only have a few issues.

    I got the scripted updated, but it still showing I'm on 5.1.3.

  • Did you restart seafile?

    I always change to a user like this if I have something like a script that needs to be run by a certain user.

    su - seafile

    Then you would be the seafile user. Run the script and then use "exit" to get back to the root user. Have to do this with virtualbox for
    certain things.

  • Yes, I ran it as 'seafile', and updated, and restart the system too.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!