Union Filesystem creation error incorrect validation on min-free-space

  • BackStory: I have a fresh install of OMV 4 that i am trying to get up and running originally running OMV 2.x and decided fresh install was the way to go as greyhole wasn't supported., planning to do unionfs and SnapRAID.

    When attempting to merge a few disks in the creation dialog i am getting a validation error on the min size property and not entirely sure why (pretty sure its a bug).

    min-free-space: The value '50G' doesn't match the pattern '/^[0-9]+[KMG]$/'.

    Also I have been running into a few of these is 4.x stable or should i go back to 3.x? Chrome didn't work 70% of the time ended up having to use firefox to get anywhere!


  • Having the same issue- even with the default 4G.

    Fresh install of OMV4 over Debian9, have a SnapRAID pool created.

    Pics attached. Error message attached.

  • No, guess it doesn't work. Ctrl+F5 ... no change in behaviour.

    OS: Windows 10, current patch
    Browser: Chrome 68.0

    Here's the stacktrace:

  • That's Ok, but what @ryecoaaron is telling you is to clear your browser cache that is why you are seeing the error

    So I tried CTRL+F5 ... thought this should be ok. Now I followed these steps:

    But the message is still the same.

    //more info: Just updated from 3.xx to 4.1.11.

    //again more info: Tried it with another browser (IE 11) ... some message.

  • Tried to uninstall union filesystem which works.

    Reinstallation was another topic - got following message on startup:

    RPC service 'UnionFilesystems' not found.
    Error #0:OMV\Rpc\Exception: RPC service 'UnionFilesystems' not found. in /usr/share/php/openmediavault/rpc/rpc.inc:99Stack trace:#0 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('UnionFilesystem...', 'getList', Array, Array, 1)#1 {main}

    And another one - see attached - during installation-process.

    At this point, I'll stop fixing union filesystem and will reinstall OMV; guess this will work or at least hope so.

  • It looks like your repos are incorrect. If you are on OMV 4, it should not be looking for php5. I think you probably had an old version of the plugin but with so many errors, I would start over.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Puuh ... this was a tough piece of work.

    When I reinstalled OMV 4.x, I disconnected (put cable off) all data-disks, only my system-M2 was already active ... installation was just fine, no problem. Then I reconnected all drives and then there was a bad surprise - grub was not loading my new installation; every time, I connected a data disk, a error similar like this (No init found. Try passing init=bootarg.) appeared: https://askubuntu.com/question…itramfs-error-during-boot

    I found out, that my installation-USB-Stick was ! sda ! [wrong mount order] during installation, so grub put no boot-partition/-information on sda (my M2) after I removed the USB-Stick.

    I found the solution (fix grub2) in this blog: https://dcandy.wordpress.com/2…ls-to-install-bootloader/

    Finally, I looks quite fine to me ... OMV is reachable, data is already there ... hope this will last for a long time ^^

    Thank you for your support!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!