OMV can´t find ethernet

  • Hi there,

    After having some troubles I installed a freshly OMV 4 to a brand new SSD.
    OMV 4 is running on a HP ProLiant MicroServer gen8.

    During installation the installation manager was able to start the ethernet interfaces... via DHCP they got IPv4.

    But, after starting OMV 4 from SSD, I always get the error that "no ethernet interfaces are available". Having this error for some days now after installation.
    Before having this trouble, OMV 4 was running on the same server without any problems.

    Executed "ip link status" for getting more informations...

    Hoping for a solution...

  • Try this:

    1. Shut down the server, disconnect the data drives.
    2. Turn on the server see if it connects.

    If it does, then shut it down, and reconnect your data drives.

    Otherwise, try a diff't NIC card, and check for its light activity.

  • Change something and try again. Or just try again anyway, in case something went wrong during the installation process. The problems are not going away by themselves.

    Have you tried reinstalling? Possibly after changing stuff around a little. Check bios settings. Possibly upgrade bios and other firmware.

    Why do you have the bootloader on a thumbdrive and not on the SSD? Are there other problems with the installation?

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • In mode AHCI the ProLiant Microserver can not boot from the ODD SATA-port, where the system-SSD is connect to.
    So, it boots a bootloader from USB, which is pointing to the system-SSD. This worked for years until now.

    I already installed OMV many times... "no ethernet available". There is nothing during installation I can do different.

    Does the screenshot offer more informations about the interfaces ?

  • This is the output from my ip link show;

    ip link show enp2s0
    2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether 9c:b6:54:0b:14:a5 brd ff:ff:ff:ff:ff:ff

    It would appear eno1 is not detecting a carrier and the missing lower up tells us the NIC cannot send or receive data, which would imply it's not connected to anything :) obviously not the case.

    As you have a screen and keyboard connected you could try omv-firstaid and I think option 1 is configure network interface. The GEN8 has two interfaces one of which is for ilo, best guess would be that is eno2.

  • Good idea... I try omv-fristaid...

    The GEN8 has 3 ethernet ports. One is dedicated to iLO, 2 are for "the rest". I don´t know if there are 2 or 3 NICs inside.
    In iLO you can choose for iLO to work from eno1 or 2. Thought, it would be a kind of bridge to use eno1 or 2 in case the iLO port is broken.

    At the moment I have connected eno1 AND 2 to network, iLO port is not connected.

  • I've seen those connection refused errors before, but having searched the forum I can't find one that was solved, but I did find something that allows you to boot from the ODD, configuration is done from iLO. I use a GEN7 but OMV is installed on a USB and I have a drive attached to that port, you install and boot from a USB but move docker and vm setup to the SSD.
    The only other option I can think of is to do a debian net install (minimal) that would/should bring up the network then install OMV, some users have found this to be the only option to resolve hardware problems.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!