ftp not running on reboot until I restart the service..

  • I set up and enabled ftp but on every reboot its set to enabled: green, running: red and not functional.
    I have to manually disable and re-enable ftp.
    when I first do that, I get errors like: https://pastebin.com/ag2KaKNk

    then I have to retry in order to get it running, and then it actually works..
    Until I reboot I have the same issue again.

    how do I fix this?

  • I am facing the same problem of FTP not running after reboot or once the server started up after shutdown.

    I downloaded OMV 5.0.5 from https://sourceforge.net/projects/openmediavault/files/5.0.5/
    Now I notice that my OMV version is 5.2.1-1 (Usul) on System Info in OMV web GUI. (please see attached image)

    The question is: Which is my current version of OMV? (5.0.5 or 5.2.1-1?) My OMV automatically updated to 5.2.1-1 through Web GUI? (sorry that I am asking a stupid question but it is really a question)

  • dear all,
    same issue here... I have to manually disable and re-enable ftp after any reboot (version omv 5.2.1-1)

    error I got from log ftp:

    Jan 05 11:05:29 raspberrypi4 proftpd[930]: Starting ftp server: proftpd2020-01-05 11:05:29,630 raspberrypi4 proftpd[990] mod_ctrls/0.9.5: unable to chown local socket /var/run/proftpd/proftpd.sock: No such file or directory
    Jan 05 11:05:34 raspberrypi4 proftpd[1252]: - ProFTPD 1.3.6 (stable) (built Wed Oct 23 2019 14:22:38 UTC) standalone mode STARTUP
    Jan 05 11:05:34 raspberrypi4 proftpd[930]: .
    Jan 05 11:05:34 raspberrypi4 proftpd[1255]: Starting ftp server: proftpdstart-stop-daemon: matching on world-writable pidfile /run/proftpd.pid is insecure
    Jan 05 11:05:34 raspberrypi4 proftpd[1255]: failed!

    What can I do?

    Info report
    = OS/Debian information
    No LSB modules are available.
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 10 (buster)
    Release: 10
    Codename: buster

    = openmediavault information
    Release: 5.2.1-1
    Codename: Usul

  • Hello try to enable startup proftpd during boot or check the proftpd status and restart it....

    The last time I saw eclipse I was programming :thumbup:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!