Problem booting up with LUKS and UnionFileSystem

  • I'm using OMV5 + Luks + SnapRaid + Union/MergerFS and also had a problem of rebooting into emergency mode.


    I hava managed to workaround this issue by adding "noauto" option in mergerfs entry in /etc/fstab. This disables the automatic mounting of mergerfs partition at boot (which cannot possibly succeed without unlocking Luks first) and causes OMV5 to reboot normally with GUI available. Then I unlock encrypted drives manually and, after that manually mount the mergerfs partition

    Code
    mount /srv/random-mergerfs-uuid-copied-from-fstab

    After that, shared folders immediately become available via SMB. Also, branches tab in UnionFS plugin gets updated automatically. I didn't test NFS, though. I don't mind doing manual actions after reboot because typing in Luks passphrase manually is required anyway. It would be nice if there was "mount UnionFS" button in GUI, though...

  • I run into the same problem after having a perfectly working UnionFS without LUKS i readded the UnionFS and applied encryption and now it's not working. i've tried peca89's solution "noauto" but still it boots into rec.mode. Does this work with MergeFS instead? How do I get past the error?

  • I have no idea, really. This is my first experience with OMV. I made it working without actual understanding of what's behind. For your reference, here is my fstab file:



    And the script I created and placed in /usr/local/bin to unlock all drives with the same password:


  • Thanks peca89 ! I've managed to manually edit the fstab file so ignore mounting the encrypted mergeFS array and then i am manually decrypting and mounting it from the dashboard menu. Since I seldom restarts my server I have no problem with it but I hope this gets fixed in the near future.

  • Thanks peca89


    The noauto worked only that when I now unlock the encrypted drives there broken. The fuse.mergerfs filesystem will not mount. It would really be become simpler if this was fixed in the future by the devs, because it really is a hassle when one cant properly restart the system.

  • Change the options in the mntent section. If you edit the pool in the web interface, it will add them back though. I guess I could add a checkbox to disable them.

    Is this something that can be implemented in the near future? Namely remove all the "x-systemd.requires" options from the union pools entry in fstab. And maybe a reload/check function for mergerfs so that all branches shows correct disks and not n/a without the need of modify mergerfs?

  • Is this something that can be implemented in the near future?

    It is implemented in the mergerfsfolders plugin. I haven't gotten around to adding it to the unionfilesystems plugin.

    And maybe a reload/check function for mergerfs so that all branches shows correct disks and not n/a without the need of modify mergerfs?

    I don't know what this means.

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!