Problem booting up with LUKS and UnionFileSystem

  • I'm using OMV5 + Luks + SnapRaid + Union/MergerFS and also had a problem of rebooting into emergency mode.


    I hava managed to workaround this issue by adding "noauto" option in mergerfs entry in /etc/fstab. This disables the automatic mounting of mergerfs partition at boot (which cannot possibly succeed without unlocking Luks first) and causes OMV5 to reboot normally with GUI available. Then I unlock encrypted drives manually and, after that manually mount the mergerfs partition

    Code
    mount /srv/random-mergerfs-uuid-copied-from-fstab

    After that, shared folders immediately become available via SMB. Also, branches tab in UnionFS plugin gets updated automatically. I didn't test NFS, though. I don't mind doing manual actions after reboot because typing in Luks passphrase manually is required anyway. It would be nice if there was "mount UnionFS" button in GUI, though...

  • I run into the same problem after having a perfectly working UnionFS without LUKS i readded the UnionFS and applied encryption and now it's not working. i've tried peca89's solution "noauto" but still it boots into rec.mode. Does this work with MergeFS instead? How do I get past the error?

  • I have no idea, really. This is my first experience with OMV. I made it working without actual understanding of what's behind. For your reference, here is my fstab file:



    And the script I created and placed in /usr/local/bin to unlock all drives with the same password:


  • Thanks peca89 ! I've managed to manually edit the fstab file so ignore mounting the encrypted mergeFS array and then i am manually decrypting and mounting it from the dashboard menu. Since I seldom restarts my server I have no problem with it but I hope this gets fixed in the near future.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!