Applying configurations in the web-interface takes forever

  • I just recently installed OMV5 on my old machine (which used to run regular debian buster flawlessly).


    However, I notice that changing configurations in the web interface and applying them takes an incredibly long time. I'm talking about between 2-5 minutes to apply even simple settings like 'mounting a partition'.


    This seems to be universal. It doesn't matter which setting I'm trying to apply. They all take a ridiculous long amount of time to apply

    • Official Post

    OMV 5 uses saltstack for configuration management. It does many more things that older versions of OMV didn't do. On slower systems, this is going to be worse. Not much can be done to avoid this other than wait for all changes before clicking Apply.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    Do you mean, making several changes via the GUI before clicking Apply?

    Yes. Then you just have one long apply instead of many long applies. I realize there are some cases where this is not possible but I don't have a better solution.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    New installs have /sharedfolders disabled and that greatly speeds up apply actions.


    Add OMV_SHAREDFOLDERS_DIR_ENABLED="NO" to /etc/default/openmediavault


    Then


    omv-salt stage run prepare

    omv-salt deploy run systemd


    reboot

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Thank You for so fast response

    New installs have /sharedfolders disabled and that greatly speeds up apply actions.

    I've installed OMV5 with this script on Armbian buster 4.14.170 on Odroid HC1 and it already has OMV_SHAREDFOLDERS_DIR_ENABLED="NO" in /etc/default/openmediavault


    omv-salt stage run prepare and omv-salt deploy run systemd was succeeded but did not speed up apply actions

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!