Plex cannot start "because of unavailable resources or another system error"

  • I have look for some solution but didnt find that help, so ...


    I have clean install Plex for a little server with only a USB drive (4Tb) connected. I cannot apply to start Plex as I got this error :



    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl start 'plexmediaserver' 2>&1' with exit code '1': Job for plexmediaserver.service failed because of unavailable resources or another system error. See "systemctl status plexmediaserver.service" and "journalctl -xe" for details.
    Error #0: OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl start 'plexmediaserver' 2>&1' with exit code '1': Job for plexmediaserver.service failed because of unavailable resources or another system error. See "systemctl status plexmediaserver.service" and "journalctl -xe" for details. in /usr/share/php/openmediavault/system/process.inc:182 Stack trace: #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1) #1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false) #2 /usr/share/openmediavault/engined/module/plexmediaserver.inc(46): OMV\System\SystemCtl->enable(true) #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModulePlexMediaServer->startService() #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array) #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array) #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array) #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatus4a...', '/tmp/bgoutputct...') #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure)) #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array) #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array) #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array) #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array) #13 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1) #14 {main}

    Help please.

  • Hello,
    Same problem here, it seems like the service fails to start. The first time I installed plex it worked fine, but after a reboot the service just won't restart and the same error keeps showing up.

  • something seriously broke this after the last update. Mine failed during the update. Now i have completely uninstalled and re-installed 3x and still the the same


  • I tried a number of times to:

    apt remove plexmediaserver

    apt purge plexmediaserver

    userdel plex


    then i also deleted /var/lib/plexmediaserver after the above.

    I have then reinstalled via the plugin


    when i try to access http://myserver:32400/web/

    i get the error "No Soup For You!" The server you are accessing doesn't want to let you in"


    when i try to access http://myserver:32400/web/index.html

    i log into my plex.tv account, but if i click on "Your Media" - i get add plexmediaserver option and don"t see any way to setup my own media

  • I am wondering if they made a change to the way they do device discovery. i never had a rule for 32600 before when it was working.


    Apr 26, 2020 22:50:51.508 [0x7f98b25dc700] DEBUG - Grabber: HDHomerun discovered 0 compatible devices.

    Apr 26, 2020 22:50:51.508 [0x7f98b25dc700] DEBUG - HTTP requesting POST http://127.0.0.1:32600/devices/discover

    Apr 26, 2020 22:50:51.511 [0x7f98b25dc700] ERROR - Error issuing curl_easy_perform(handle): 7

    Apr 26, 2020 22:50:51.511 [0x7f98b25dc700] WARN - HTTP error requesting POST http://127.0.0.1:32600/devices/discover (7, Couldn't connect to server) (Failed to connect to 127.0.0.1 port 32600: Connection refused)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!