Urbackup - (err_cannot_create_subdir). Permission denied (code: 13)

  • Hello,

    my urbackup source path is not available any more because the HDD witch contained the share died. So now the lesson is learned an i bought two Hdds, an setup an Raid1 array in OMV.

    Same setup as last time i change the path in Urbackup to /srv/dev-disk-by-label-Backups - Under Filsystems --> Label the Raid1array is called "Backups".

    Now im getting an error in Urbackup -->:

    "The directory where UrBackup will save backups is inaccessible. Please fix that by modifying this folder in 'Settings' or by giving UrBackup rights to access this directory. (err_cannot_create_subdir). Permission denied (code: 13)"


    When i change the path to: /srv/dev-disk-by-label-Backups/urbackup


    Detailed error info:

    Code
    Can access /
    Can access /srv
    Cannot access /srv/dev-disk-by-label-Backups7urbackup. No such file or directory (code: 2)

    Im not sure way there is now a permission issue?


    Openmediavault v:4.1.35-1

    urbackup v:2.4.12


    best regards

  • Please fix that by modifying this folder in 'Settings' or by giving UrBackup rights to access this directory.

    I assume you installed UrBackup as a servicer, not in docker:

    Make sure the directory is owned by user "urbackup" and that he has read/write access.

  • Hello,


    i installed Urbackup via the OMV-extras - should there be a user Urbackup?

    I think i found it :)



    Same problem as before - i restarted the server twice:


    The directory where UrBackup will save backups is inaccessible. Please fix that by modifying this folder in 'Settings' or by giving UrBackup rights to access this directory. (err_folder_not_found). No such file or directory (code: 2)

    Detailed error info:


    Code
    Can access /
    Can access /srv
    Can access /srv/dev-disk-by-label-Backups
    Cannot access /srv/dev-disk-by-label-Backups/Files. No such file or directory (code: 2)
  • Not sure how the plugin works. You can check in the GUI of OMV.

    If not post the output of


    id urbackup


    from CLI. This will tell us if the user exists and which group he is member of.


    Also post the output of

    ls -al PathToFolderBackup so we can see the ownership and permission of the backup folder

  • When i change the path to: /srv/dev-disk-by-label-Backups/urbackup

    Ah sorry,


    probably you only have to create this folder as shared folder in OMV.


    So create a shared folder "urbackup" on the drive with the label "Backups".

  • Cannot access /srv/dev-disk-by-label-Backups7urbackup. No such file or directory (code: 2)

    This indicates that you made a typo.

    /srv/dev-disk-by-label-Backups7urbackup

    should be

    /srv/dev-disk-by-label-Backups/urbackup

  • I tried :


    Code
    Cannot access /srv/dev-disk-by-label-Backups/urbackup. No such file or directory (code: 2)
    Code
    Cannot access /srv/dev-disk-by-label-Backups/Files. No such file or directory (code: 2)

    Every time i give a path to a folder(which exists under the path) im getting this error so, i thought no Folder - im not getting an error but urback can`t write because when i trigger an backup nothings happens. There must be a write issue.


    HINT: The share is a Raid1 (/srv/dev-disk-by-label-Backups/***) and is accessible via SMB

  • The output above


    Code
    sudo ls -al /srv/dev-disk-by-label-Backups/
    total 20
    drwxrwxrwx 1 root root 74 Apr 5 09:05 .
    drwxr-xr-x 5 root root 4096 Apr 3 17:21 ..
    drwxrwxrwx 1 urbackup urbackup 0 Apr 5 08:31 clients
    drwxrwsr--+ 1 root urbackup 50 Apr 5 08:40 Raid1Backups
    drwxrwxrwx 1 urbackup urbackup 0 Apr 5 09:05 urbackup_tmp_files

    Showes neither a urbackup nor a Files folder.

  • I found the solution it was a wrong path indeed: Thats the correct one:

    /srv/dev-disk-by-label-Backups/Raid1Backups/Files


    But if you add a sub folder you must run the ACL option do add the r+w flag:

    "Shared Folders":


    After that klick on Apply.This is setting the r+w access.


    I guidline on how the path works:

    /srv/dev-disk-by-label-Backups/Raid1Backups/Files

    Backups is set under: "Shared Folders" - Devices - in my case its called Backups

    Raid1Backups is set under: "SMB/CFIS" - "Shared Folder" - in my case its called Raid1Backups


    If you reinstalled urbackup you need to uninstall install the client because the PGP keys are now new. If you dont you get an error Client rejected.

    In the Urbackup config window, add the client ip adress and click on the Checkbox (when the client is added) after that go to withe Selected an do y fully File and IMG backup.


    Im guessing i did set the write permission last time in the shell an then forgot.......

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!