Performance Statistics losing data after reboot

  • Since installing system updates around two weeks ago (~April 10), the Performance Statistics collected since then are not persistent after rebooting. Statistics before that date are still present.


    When checked immediately after restarting, the statistics show "last update: April 10" and after refreshing there is no data from around that date to the present.


    I also tried to check previous boot logs with: sudo journalctl -ef -b -1 which fails with: "Specifying boot ID or boot offset has no effect, no persistent journal was found." In the OMV GUI, the boot log has only the last boot, but the Syslog goes back beyond the current boot.


    What has happened?


    Possibly related to this reported issue with FlashMemory plugin: FlasMemory (Folder2ram) plugin issue

  • Puzzling:


    Before rebooting, I checked the timestamps on the .rrd files in /var/lib/rrdcached/db/localhost/* and they were recent. eg April 27. Then after rebooting, they are dated back to April 5.


    Also, after timestamps update (every 15 minutes), the file size does not change.


    How does this happen?

  • BigBro Does your problem go away when you clear /var?

    Mine does not look full:


    Very frustrating. I still haven't found a solution to this.

  • i hope i have the solution:


    # vim /lib/systemd/system/folder2ram_shutdown.service


    add "ExecStartPre=" before "ExecStart="


    Code
    RemainAfterExit=yes
    ExecStartPre=/sbin/folder2ram -syncall
    ExecStart=/sbin/folder2ram -umountall

    maybe it is also a good idea to sync hourly (cron) in case NAS will crash

  • Thanks, I'll try ExecStartPre=/sbin/folder2ram -syncall.


    I already tried the first solution of deleting/moving the /var/lib/collectd/rrd/localhost directory which contains .rrd files (much like in /var/lib/rrdcached/db/localhost) as mentioned at RE: error in syslog regarding rrdcached which I found since I had the same type of system log errors mentioned in RE: error in syslog regarding rrdcached. After this, the data seemed to survive a couple of test reboots and I thought it was solved, but after a day, rebooting again wiped out previous data.

  • "illegal attempt to update using time" is rised because rrdcached needs some time to start and in meantime collectd already try to start with commiting data to rrd db files which fails. I have same errors in log at the beginning but ca. 5 sec later are they gone.



    not to use folder2ram is not an option for me because im using WD My Cloud Home with Debian/OMV installation and /var/lib is normally located in flash memory.

  • Hmm... I just tried rebooting after about a day of having tried your fix, and so far the data survived. Btw, my /var/lib/collectd/rrd/* is still empty due to the previous fix I tried and I have not (yet) reversed that change.


    Did you do systemctl daemon-reload after making the changes to /lib/systemd/system/folder2ram_shutdown.service?

  • Now I have daily synchronization in /etc/cron.d/openmediavault-userdefined and plus one in folder2ram.shutdown


    The data survived the last restart and if not, I lose the date collected since last night, maximum

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!