No webui after updates

  • Hoping someone can help a noob. OMV 4 on a nanopiM4 sbc was running just nice until installing updates from the webui a few weeks back. Now when I try to go to the OMV web page to login I get a http error 500.

    I can login via Putty.

    I can access my HDD's via samba but they dont show up in the Windows File Explorer like they used to. Now I have to specifically go to the server IP for it to list them.

    sabNZB runs just fine.

    Have tried <sudo apt update> again thru command line and it ran without errors but no fix.

    Think I even tried a reinstall of OMV but again no fix.

    Have searched the forum to no avail but seems that results from dpkg -l | grep openmediavault and df -h are common requests to get help so here it is:

    root@nanopim4:~# dpkg -l | grep openmediavault

    ii openmediavault 4.1.35-1 all openmediavault - The open network attached storage solution

    ii openmediavault-backup 4.0.6 all backup plugin for OpenMediaVault.

    ii openmediavault-docker-gui 4.1.6 all OpenMediaVault plugin for Docker

    ii openmediavault-fail2ban 4.0.2 all OpenMediaVault Fail2ban plugin

    ii openmediavault-flashmemory 4.2.2 all folder2ram plugin for OpenMediaVault

    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive

    ii openmediavault-mysql 4.1.1 all MySQL plugin for OpenMediaVault.

    ii openmediavault-netatalk 4.0.7-1 all OpenMediaVault netatalk (AppleTalk Protocol Suite) plugin

    ii openmediavault-nginx 4.0.4 all Nginx plugin for OpenMediaVault.

    ii openmediavault-omvextrasorg 4.1.16 all Package Repositories for OpenMediaVault

    ii openmediavault-openvpn 4.0.4 all OpenVPN plugin for OpenMediaVault.

    ii openmediavault-resetperms 3.3 all Reset Permissions

    root@nanopim4:~# df -h

    Filesystem Size Used Avail Use% Mounted on

    udev 960M 0 960M 0% /dev

    tmpfs 193M 8.3M 185M 5% /run

    /dev/mmcblk0p2 7.4G 2.7G 4.2G 40% /

    tmpfs 964M 0 964M 0% /dev/shm

    tmpfs 5.0M 8.0K 5.0M 1% /run/lock

    tmpfs 964M 0 964M 0% /sys/fs/cgroup

    tmpfs 964M 4.0K 964M 1% /tmp

    /dev/mmcblk0p1 58M 36M 20M 65% /boot

    /dev/zram0 49M 12M 34M 27% /var/log

    /dev/mmcblk0p3 23G 64K 23G 1% /srv/dev-disk-by-id-mmc-SC32G_0xe882f291-part3

    folder2ram 964M 11M 953M 2% /var/log.hdd

    folder2ram 964M 0 964M 0% /var/tmp

    folder2ram 964M 316K 963M 1% /var/lib/openmediavault/rrd

    folder2ram 964M 876K 963M 1% /var/spool

    folder2ram 964M 14M 950M 2% /var/lib/rrdcached

    folder2ram 964M 12K 964M 1% /var/lib/monit

    folder2ram 964M 4.0K 964M 1% /var/lib/netatalk/CNID

    folder2ram 964M 420K 963M 1% /var/cache/samba

    /dev/sdb5 1.9T 941M 1.9T 1% /sharedfolders/nanopi-disk1

    /dev/sde1 1.9T 175M 1.9T 1% /sharedfolders/nanopi-disk4

    /dev/sda1 7.3T 3.8T 3.6T 52% /srv/dev-disk-by-label-8TB-202001

    /dev/sdd1 1.9T 334G 1.5T 18% /sharedfolders/nanopi-disk3

    /dev/sdc2 3.7T 3.1T 588G 85% /sharedfolders/nanopi-disk2

    tmpfs 193M 0 193M 0% /run/user/0

    Thanks in advance for any assistance as my backup is a little out of date and would prefer not to do a fresh install.

    • Official Post

    Did you try anything from omv-firstaid?

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8 plugins source code and issue tracker - github - changelogs

    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Yes but had no joy there either as nothing I tried helped.

    BTW, I also had a look at the nginx status:

    root@nanopim4:~# service nginx status

    â nginx.service - A high performance web server and a reverse proxy server

    Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)

    Active: active (running) since Mon 2020-05-11 21:34:15 AEST; 12min ago

    Docs: man:nginx(8)

    Process: 1753 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

    Process: 1637 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

    Main PID: 1765 (nginx)

    Tasks: 7 (limit: 4915)

    Memory: 9.3M

    CPU: 722ms

    CGroup: /system.slice/nginx.service

    ââ1765 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;

    ââ1766 nginx: worker process

    ââ1767 nginx: worker process

    ââ1768 nginx: worker process

    ââ1770 nginx: worker process

    ââ1771 nginx: worker process

    ââ1772 nginx: worker process

  • Here's the output:

    root@nanopim4:~# systemctl status wsdd.service

    â wsdd.service - Web Services Dynamic Discovery host daemon

    Loaded: loaded (/lib/systemd/system/wsdd.service; enabled; vendor preset: enabled)

    Active: active (running) since Mon 2020-05-11 21:34:21 AEST; 1h 35min ago

    Main PID: 2445 (python3)

    Tasks: 1 (limit: 4915)

    Memory: 12.1M

    CPU: 1.552s

    CGroup: /system.slice/wsdd.service

    ââ2445 python3 /usr/sbin/ --shortlog --workgroup=SOHO

    May 11 21:34:21 nanopim4 systemd[1]: Started Web Services Dynamic Discovery host daemon.

    May 11 21:34:22 nanopim4[2445]: WARNING: no interface given, using all interfaces

    Edited once, last by jokemeister: Realised I had not copied the whole output. ().

  • Thanks for any help. Having same issue.

    Dockers all working fine. Can see all the folders, just can't get into web gui with desktop, but can with Surface laptop. Tried Crome and Firefox, reset network, and still can't get into gui. The only thing that might have changed is I accidentally shut the server down by hitting its power button ( does a safe shutdown, not power off) When stated up couldn't get into gui.

    Tried omv-firstaid, didn't work, but didn't try using surface first. Don't know why this is only happening on wired in desktop.

    Thanks, ML

  • Here is output of wsdd service

    ● wsdd.service - Web Services Dynamic Discovery host daemon

    Loaded: loaded (/lib/systemd/system/wsdd.service; enabled; vendor preset: enabled)

    Active: active (running) since Sun 2020-05-10 16:56:58 CDT; 17h ago

    Main PID: 1238 (python3)

    Tasks: 1 (limit: 4915)

    Memory: 15.4M

    CPU: 412ms

    CGroup: /system.slice/wsdd.service

    └─1238 python3 /usr/sbin/ --shortlog --workgroup=Lewis Family

    May 10 16:56:58 LewisServer systemd[1]: Started Web Services Dynamic Discovery host daemon.

    May 10 16:56:59 LewisServer[1238]: WARNING: no interface given, using all interfaces

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!