Portainer connect still not right

  • Lately I think have more issue to get portainer working, even if I uninstall docker reinstall them I try to do the same for portainer no matter what I am landing on the the site can not be reached,

    by the way since the last version of omv5 in the pop up window we can not see as before if something getting wrong or not it just says install or uninstall anyway right now my only work around is to run

    Code
    docker run -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer

    basically after each reboot?

  • Where is the directory portainer_data being created?


    Are you sure you have a vaild Docker Storage location set in OMV-Extras | Docker?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Where is the directory portainer_data being created?


    Are you sure you have a vaild Docker Storage location set in OMV-Extras | Docker?

    Docker storage is: /srv/dev-disk-by-label-WD_10TB_1/docker so after passing the argument from above I got 2 portainers container running one doing nothing the other one see the log below.

  • Don't have more than one Portainer container running. You should delete both of them and start over.


    Is there some reason you can't use the OMV-Extras pages in OMV to install/remove Portainer?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • There is no reason your docker run command should not work so long as the user you run it as has the correct permissions to be able to write into the location the image needs to.


    I asked you where your portainer_data directory is located but got no answer. And by located, I mean where in your actual filesystem does it sit?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Sorry not sure if I understood, the file system is on an microsd anyway after each restart no portainer installed if I click install and click on open web it land on a page : the site can't be reached. since ths portainer as you can see in my jpeg above is not attached to port 9000.

  • Portainer creates and uses a directory named portainer_data to store things it needs. You need to find out where this directory is. If it doesn't exist Portainer probably will not be persistent across reboots.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Nefertiti

    Added the Label OMV 0.5

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!