Please help ! bad write speed

  • Hey ,

    im running OMV5 on a Raspberry pi 4 with WD elements 5 TB.


    I had good write speed on my drive around 110 mb/s.

    After i changed Advanced Power Managment settings to 127 my write speed dropped to around 12mb/s

    Even if i revert all settings to disabled my write speed remains slow.


    Anyone who can help me?

    Thanks in advance

  • astrix

    Changed the title of the thread from “Please help :) bad write speed” to “Please help ! bad write speed”.
  • Rebuild it.

    The next time around clone your SD-card, to a 2nd card. It's dirt simple. With backup, if something like this were to happen again, you'd have a known good backup to revert to.

    I rebuild it. Made a backup and tried again. Problem persists after activating APM. Maybe hd-idle is a solution?

  • There may be more involved with this issue than OMV, especially if the hdparm commands on the CLI don't work. (I'm assuming you tried macom 's suggestion.) Note that OMV is a server management tool, that is loaded on top of Raspbian.

    This issue may have something to do with Raspbian or the hard drive itself. If the hard drive doesn't fully support APM, or if WD's USB to SATA bridge is filtering drive commands, attempting to configure APM is not going to work (obviously). You might check with the WD website to see if your model of WD - USB drive fully supports APM and hdparm commands.

    Alternately, note that the power savings for idling one drive is minuscule to nonexistent (depending on usage) and it's arguable as to, whether or not, there's any savings on drive wear and tear by spinning the drive down. (In fact, regardless of size, the greatest wear, tear, and power consumption is involved in spinning an electrical motor up.)

    The easiest choice is not to attempt to idle the drive.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!