FTP root folder seems wrong

  • I installed OMV 5 fresh (with an old hard disk though) and I seem to have problems with the FTP server.

    From what I understand the login works fine but it appears as if the default folder is the root one.

    I therefore get an error message regarding the permissions:



    I try to connect locally in my LAN, no firewall configuration yet and - as mentioned - a fresh install.


    I also tried to set the default root folder in the advanced settings

    Code
    DefaultRoot /srv/dev-disk-by-label-Data/

    But with no success.


    The /etc/proftpd/proftpd.conf looks like this:



    Looks all fine to me so what am I missing?


    Thanks a lot!

    Tobias



    #### EDIT ####


    Looks like it works when I switch to SFTP. However the users can now traverse throught the whole filesystem. Before they saw only the shared folders. If there would be a way of changing this, I would also be fine with SFTP instead.

  • Are you logging into your FTP server with the OMV root account or with a separately created user?

    In the latter case, in OMV's FTP settings you can define which shared folders that user is allowed to see and access.

  • I tried with both.

    SFTP requires the ssh group to be set for the user so maybe that enables something I missed.

    However, if you mean the "Shares"-Option I set a shared folder there. This is the "Files" in the configuration. Still that doesn't change anything.


    FTPS doesn't work and SFTP shows the whole range of the file system.

  • Okay I found a part of a solution.


    It seems the (Filezilla) client did not reuse SSL session and was rejecting the data connection.


    Code
    That was fixed by setting the parameter "No session reuse required (The requirement that the SSL session from the control connection is reused for data connections is not required.)"


    In the control panel.

    Now the folder is shown almost correctly since the "root" folder is "/srv/ftp" now. I understand this is the normal behaviour and if I enter then "/Files" in FileZilla I can actually reach the folder I want the users to be in.

    But it is not shown nor is it the chosen root folder.


    Any idea how this can be achieved?

    I already tried setting

    Code
    DefaultRoot /srv/dev-disk-by-label-Data/Files
    DefaultChdir /srv/dev-disk-by-label-Data/Files


    in both "Settings" and "SSL/TLS" input fields and even other combinations like

    Code
    DefaultRoot /Files
    DefaultChdir /Files


    etc. but to no success!

  • the ftp service point to /srv/ftp which is root permission, it doesn't point to the sharefoler that I created: dev-disk-by-label-storage/public.


    this is a bug!


    Solution:

    ln -sf /srv/ftp dev-disk-by-label-storage/public

    and select /srv/ftp dev-disk-by-label-storage/public as ftp for sharefolder.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!