OMV shuts down even that Power Management is disabled

  • Hello everybody,


    i recently updated from 4.x to 5.x over christmas.


    Normally my systems starts on various times in the afternoon (RTC) and shutdown at 11:00pm in the evening (Power Management).


    Because I need to perform a extended HDD check via "smartctl -t long" at my disk, i disabled the shutdown via the Power Management menue.


    Even that all entries are disabled, the server shuts down automatically.


    Is there any known bug or hint that could help me out.


    Thank you so far.



    PS: After checking the logfiles, it seems that after disabling the power management schedule it does not shutdown at 11:00pm, but very regular at 00:22:44 (last log-entries in /var/log/messages)

  • AlessandroZero

    Changed the title of the thread from “OMV shutsdown even Power Management is disabled” to “OMV shuts down even that Power Management is disabled”.
    • Official Post

    There was an issue which has been fixed with 5.5.20

    But this does not explain why the time of execution changed.


    Quote

    openmediavault 5.5.20

    • Improved PHP and Python block device and filesystem implementation. Re-add usage of /dev/disk/by-uuid device files for all filesystems (except BTRFS) to workaround problems with JMicron based USB enclosures.
    • Issue #894: Disabled cron jobs are still executed.
    • Issue #896: Improve UDEV rule to fix issues with JMS567 SATA 6Gb/s bridge based USB enclosures.
  • Hello,


    thanks for the information. I updated now to 5.5.21.


    Anyway, the crontabs were already empty before my update...


    But you are right. I also don't see a correlation to the time. The only thing that could maybe influence it would be an installed VDR-server (headless).

    I've checked the config-file but i disabled the --shutdown=/usr/lib/vdr/vdr-shutdown.wrapper in /etc/vdr/conf.d/00-vdr.conf already years ago.


    To be sure, I've set the entries MinEventTimeouts and MinUserInactivity now also to 0.

  • Maybe you have a script in /etc/cron.* which shuts the system down. I'm also wondering if the watchdog service might shutdown the system? Do you see anything useful in /var/log/daemon.log or /var/log/syslog at the same time?

  • Hi,


    thank you for your reply.


    After checking the logs again, i found at least how omv does the shutdown - sorry if that was obvious for all of you:


    root@xyz:/etc# grep -r poweroff *

    cron.d/openmediavault-powermngmt:* 1 * * 2 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 2 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 3 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 4 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 5 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 6 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 1 * * 1 root systemctl poweroff >/dev/null 2>&1


    So the question is, was it there when my problem occured or not.... I'm not able to say...


    I disabled it via the menue for tonight, lets see what happens:


    root@meiersrv:/etc# grep -r poweroff *

    cron.d/openmediavault-powermngmt:* 1 * * 2 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 2 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 3 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 5 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 23 * * 6 root systemctl poweroff >/dev/null 2>&1

    cron.d/openmediavault-powermngmt:* 1 * * 1 root systemctl poweroff >/dev/null 2>&1


    Best regards and thanks so far...

  • OK, happily, the server was still running this morning.


    It seems that the issue is fixed, even if I still can't image why the server shuted down at 0:22 when everything was disabled.


    Thanks

  • votdev

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!