Update Duplicati? Database Error? I'm asked to update every time I login to Duplicati - update doesn't stay updated

  • Hello everyone,


    I've got an OMV Installation with the Duplicati plugin.


    I run OMV on a RaspberryPI and it works wonderfully! All the backups were working without a hitch until some months ago - I've been unable to fix it since then and am now posting because I'm not sure how else to resolve this.


    It all worked well until one day I logged into Duplicati to verify things were working okay and noticed there as an update. Once I clicked to 'update', I thought all was well. It appeared to have applied the update. I was trying to update to: New update found: 2.0.5.1_beta_2020-01-18


    Then the next day, I noticed my backups were breaking - stating a difference in the database versions. When I logged into Duplicati, I saw the same update notification as well as the numerous backup failure notices. It was as if my update from the day before had not properly remained applied (I did reboot the server in between days).


    Here is the error message that I see for all my backup jobs now:

    The database has version 10 but the largest supported version is 8. This is likely caused by upgrading to a newer version and then downgrading. If this is the case, there is likely a backup file of the previous database version in the folder /root/.config/Duplicati.


    I ran across this online: https://forum.duplicati.com/t/…pported-version-is-7/5472


    Seems pretty similar to issues I was having - and I can confirm what that user saw: that there are updates in: /usr/share/Duplicati/updates


    But I did not see those same updates in: ~/.config/Duplicati/updates


    I copied over the updates to ~/.config/Duplicati/updates , but noticed not difference in execution of things (should I have ran a command after moving the updates over?)


    One of the users said:

    Quote

    This happens because the update fails to load for some reason. When you start Duplicati after an update, it will use the update and this will upgrade the database version. When you restart the machine, the update fails to load and this causes it to fall back to the previous version, which does not support the new database version.


    That seems to be accurate to me - something happens when I restart the box and then it breaks all the backups and such.


    What is the best way to try and resolve this? Can it be resolved? Am I hosed?


    I'm not a Linux god or anything of the sort - but know enough to poke around and setup some basics - all help appreciated!

  • geaves

    Approved the thread.
  • My order of operations was like this:


    Press Upgrade to the update in Duplicati - which holds only temporarily.


    Then I recreate all the databases - and run the backups and it appears to all work.


    Then inevitably by the following day (which sometimes I have to reboot the server) I get the error messages from my previous post and the update pops up again.

  • Sounds strange. What you could try

    I run Duplicati in docker and think it is great. No mono on my system ;-)

  • I'm all for moving to OMV5 - is there no upgrade from 4 to 5? Secondly, I don't know how difficult it would be to move my existing OMV4 setup and configuration to OMV5 - or how difficult it is (or even possible) to get docker on Raspberry Pi.


    Ty for your help :) I'll keep digging and do some research on moving to OMV 5!

  • is there no upgrade from 4 to 5?

    Upgrade Scripts for non-interactive major release upgrades (2->3, 3->4, 4->5)

    how difficult it is (or even possible) to get docker on Raspberry Pi.

    It is possible. Many do.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!