OMV starting Problem "emergency mode" on every start

  • Hi guys,


    i built myself a NAS machine with Debian and OMV5 and have a strange problem on every boot.

    Actually I only want to sleep my NAS (with AutoShutdown) and wake it in the morning automatically (with wakealarm/WOL) every day.

    So far so good, but the machine shows my the following on every (re)boot:

    17758-pasted-from-clipboard-jpg

    I'm in emergency mode but I don't know why and how. (I was there one time a long time ago via the OMV GUI to adapt my filesystem).

    And hence, I always have to connect a keyboard to enter my credentials because the NAS does not boot to the promt to work proper.

    Is there a pro who can me tell how to leave that emergency mode permanent? When I enter the commands on the screen, on the next boot it will show up again.

    When you need more information feel free to say what.


    Thanks.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • I seem to remember a "grub" related related root cause in another thread answered by user "dleidert". sorry no time search

    omv 5.6.16-1 (usul) on RPi4/4GB with Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Do you have somehow set wrong permissions in /etc/fstab? I somehow have the suspicion that you lack the option "user" in the nfs settings there?


    To easily verify if the fstab options are playing you a trick:

    type on the shell:  sudo nano /etc/fstab. Then uncomment with # the lines, and reboot. If it is working after that, you have narrowed down the source of your issue.

  • new4u Thanks for your hint.

    Do you mean every line commented with #?

    To be clear, it is possible that the NAS then does not start?

    I'm a little bit afraid that the machine doesn't work :-)


    I does not change something in the fstab (at least not with purpose), the only thing I did was to boot once in the CLI kernel using the GUI of OMV to adjust the size of my drives.



    mi-hol I will look to find this article with the grub, thank you.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Beamformer: I meant uncomment with # the lines, yes. One after the other, to test. If the NAS would not start then, to be honest, I don't know. I did not consider that option. But somehow maybe your disk-by-id or disk-by-label seem to be different than it is in mine (not manually modified) list:


  • Hello Beamformer, the same problem like you described happened yesterday to me. What caused it was that I had installed a new SATA-controller in a pcie-16x-slot, which the controller did not like, presenting the disk at one boot, but on the next leaving in OMV the disk as "removed".


    Therefore, can you check if your disks in section "Storage", subsection "File Systems" are all 'online' in status, and none is 'missing'?


    The solution for me was to fall back to a previous backup, and install the SATA-controller in a pcie-1x-slot, then everything was working normal.

  • new4u: ok, but what to do when the NAS doesn't start anymore? Thanks for your Screenshot, should our files look identical? I think you have other mounts than I, therefore the file should like a little different, or?


    I also use an additional SATA card (to get a fifth SATA port for my main HDD). But I also testet it without the additional SATA card (at the moment there are 2 free SATA ports - but the data drives 4 and 5 are coming and therefore I need the additional SATA card (details see description). What SATA controller do you use that works? All file systems are online in the OMV-Extras GUI. At the moment I have no backup, this is my next step wehen all is working well.


    geaves: No there is no USB drive (I consider it, but actually there is an additional SATA card)

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Hello Beamformer,


    Yes, you are right, the files would look differently. I wanted just to give you the opportunity of comparison, maybe something different in the rights or the way things are mounted (and thus creating issues) could be easier identified.


    Regarding the SATA-extension-card, I use this one with an ASM1061 chip:

    https://www.amazon.de/gp/produ…tle_o01_s00?ie=UTF8&psc=1


    However, I had to put it into a PCIe-1x-Slot, not as advertised being compatible in a PCIe-16x-Slot.


    I think if I were in your position, it would be easier to re-install OMV from scratch, simply in comparison between the effort to identify the error versus the relatively short time for going for a clean install from scratch.

  • geaves: Yes, technically you are surely right. My assumption would be, however, that a fresh new install would resolve the issue, since it seems to be rather a singular occurrence with Beamformer - otherwise the forum would be full of complaints about this issue. And given the time being already invested without resolution, my suggestion lacks technical finesse, but might still save time and lead to the desired goal - a boot without problems.

  • I was not aware that this is a repetitive issue when installing from USB flash drive. Then I agree, if there is some reproduceable problem with installing from USB flash drives, my suggestion is no sustainable solution.

  • my suggestion is no sustainable solution.

    ?( If you still have the USB boot drive, shutdown the server, plugin the USB installer flash drive, but you must select to boot from the drive you are currently booting from, most systems have an option to select the boot device.


    The system will boot normally, except this time the boot loader will continue to a login prompt, because that information is on the USB installer, login as root and run update-grub this will update the boot loader, shutdown, unplug the USB installer and it should boot.

    Raid is not a backup! Would you go skydiving without a parachute?

  • geaves: Yes I installed Debian as shown in TDL Video (

    ) from a USB. But I think I do not have the USB Drive anymore - is it possibly to create it again to update the boot loader (as in the video shown (with a newer Debian))?

    new4u so I think it is possible that you have another chip on the Sata card, so I can check another one.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

    Edited once, last by Beamformer ().

  • thanks a lot, I hope I have the "right" grub screen, see the picture. But the "e" is not supported.

    And then I should identify the boot drive, maybe you can assist me the to get the right one. It is a Sandisk 120GB SSD drive with the partitions TDL told in his video. But I'm not sure if it is sda2 in my case.

    When I'm right, it should be an ext4 partition and not the vfat?!

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • I hope I have the "right" grub screen, see the picture. But the "e" is not supported.

    No, when you hit ESC during the blue screen you two options, 'e' or 'c'

    And then I should identify the boot drive, maybe you can assist me the to get the right one

    That could be difficult as you have 3 partitions + swap on /dev/sda, now 'I'm guessing' that the vfat could be UEFI, but I don't know.


    Looking back at that thread check #11 it's another of finding what partition it's booting from

    Raid is not a backup! Would you go skydiving without a parachute?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!